Support » Plugin: Jetpack by WordPress.com » Cookies & Consents Banner widget nowhere to be found

  • Resolved lauratraveler

    (@lauratraveler)


    Hi,

    I have the latest version of Jetpack. My blog is self-hosted. I cannot find the Cookies & Consents Banner widget anywhere. Is this not available for self-hosted blogs?

    Thanks,
    Laura

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Laura, yes it is – my blog is also self-hosted and it appears in Appearance > Widgets as “Cookies & Consents banner (Jetpack)”. It should be in the “Available widgets” section.

    lauratraveler

    (@lauratraveler)

    Thanks, @qaws. Unfortunately, there’s no such widget under Available widgets for me 🙁

    Btw, does this widget automatically detect the cookies present throughout the domain and stops them from loading before receiving consent? Basically, is it a one-click widget or did you have to manually add each cookie to the widget?

    lauratraveler

    (@lauratraveler)

    @qaws Did this widget appear after the last Jetpack update? Did you have to activate it from settings or something?

    The widget is informational-only – it doesn’t do anything active such as searching for and disabling cookies. It just provides a way to link to your own Privacy Policy or Cookie Policy which should list the cookies that your site creates (including, ironically, the one from this banner). The cookies that Jetpack creates are listed here: https://jetpack.com/support/cookies/

    The widget has been available since May 2017, since Jetpack 4.9. At the time it was called “EU Cookie Law Banner (Jetpack)” so I guess they renamed it at some point. It doesn’t need activating, it should just sit in your Available Widgets list.

    Hopefully someone from Jetpack can help you with why the widget isn’t appearing.

    • This reply was modified 11 months ago by  qaws.
    primitivenet

    (@primitivenet)

    I fixed this by simply deleting and reinstalling Jetpack – the widget then appeared.

    Plugin Support Tracy

    (@tmmbecker)

    Hi @lauratraveler,

    It sounds like you may not have the Extra Sidebar Widgets module activated. You can do this on the full modules page. This handy guide explains that in more detail:

    https://jetpack.com/support/control-jetpacks-modules-on-one-page/

    Once you’ve activated that, you should see the Cookie Consent widget in the list.

    I hope that helps!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cookies & Consents Banner widget nowhere to be found’ is closed to new replies.