Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Cookie policy not displaying in Spanish

  • Resolved Gmads

    (@gmads)


    My site is not a multilanguage site, is in Spanish, and everything is updated. I installed the plugin, and went throught the wizard. As far as I understand, the cookie policy page should automatically display in one’s site language, but in my case it is not, it is shown in English. Am I missing some step? As I already had a cookie policy page, which I did by hand, is there a shortcode I could add to my existing Spanish page to only display the cookie info shown under section “7. Placed cookies” of the wizard-generated page?

    Thanks beforehand,
    Guillermo

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Leon Wimmenhoeve

    (@leonwimmenhoeve)

    Hi @gmads,

    Could you please double-check if your site language is set to Spanish (under WordPress -> Settings -> General)? It is a different setting than the user language, which leads to confusion sometimes.

    If the site language is indeed Spanish (or if you just changed it to Spanish), please navigate to WordPress -> Dashboard -> Updates -> (scroll down) update translations. This forces your site to download the latest translation files.

    Is it possible to only display the cookies section in a custom Cookie Policy. You can use the following shortcode for that: [cmplz-cookies]

    Please let me know if the above solutions do not solve the problem.

    Kind regards,
    Leon

    Hello Leon,

    As I had read other posts regarding language issues, I had already checked, but just in case, I double checked:

    https://i.postimg.cc/Hx20BxgM/doubled-checked.png

    First emphasized area: Mexican Spanish (at the General Settings page).
    Second emphasized area: WP Spanish-version (5.4.2-es_MX).
    Third emphasized area: All translations are updated.

    I added the shortcode to my original Cookie Policy page (declaracion-de-cookies), which is not as complete as the one generated by the wizard, and yes, the cookie list is displayed, though all mixed up: most of the texts in English and a few parts in Spanish: “We use Google Fonts for mostrar fuentes web.” 😀

    Well, while this could more or less work, I think it would be best to have it all in Spanish.

    I have a cache plugin (Cache Enabler), but I have also made sure of clearing it.

    The Compianz plugin version is 4.6.10.

    Thanks again for any suggestions you may have,
    Guillermo

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @gmads,

    Unfortunately, Mexican Spanish is not yet translated by the community, as is shown here:

    https://translate.wordpress.org/projects/wp-plugins/complianz-gdpr/stable/es-mx/default/

    Only, https://es.wordpress.org/plugins/complianz-gdpr/ is available.

    There are 2 ways to fix this, either change your default language to Spanish (Spain) or help us translate the plugin to Spanish (Mexico).

    If you need help with either, please let me know.

    regards Aert

    Hello Aert,

    I didn’t know that. Okay, I just changed the language to “Spanish”, cleared the cache, reran the wizard (which still listed the Google Fonts service, which I am now self-hosting since a couple of hours ago), and reloaded the page… it still showed in English.

    Yes, I could contribute to the es_mx translation, though I would need to see about the steps to do it.

    What else could we attempt to do to make this work?

    Thanks,
    Guillermo

    Plugin Contributor Leon Wimmenhoeve

    (@leonwimmenhoeve)

    Hi @gmads,

    I would advise you to update your translations file now that you’ve switched the language to es_es. You can do that via WordPress -> Dashboard -> Updates -> (scroll down) update translations.

    It is possible that the scan still finds Google Fonts. But if you are now self-hosting, you can disable the service via the wizard.

    If you are interested in translating our plugin to Mexican English, you can start right away at https://translate.wordpress.org/projects/wp-plugins/complianz-gdpr/dev/es-mx/default/. For more questions about translations, you can also reach out to us via support(at)complianz.io.

    Kind regards,
    Leon

    Hello Leon,

    Ah! Yes, the update page indicated that updates were available. That did it. So now the policy is being displayed in Spanish. Thanks!

    Regarding the fonts service, I had disabled it manually at one of the steps of the wizard, but I saw it listed at the end. It is not critical.

    Okay, I’ll check the translation page and work on it.

    Thanks once again both for your help.
    Guillermo

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.