Support » Plugin: Beautiful Cookie Consent Banner » Cookie Notice shows up every time when logged in as admin

  • Resolved Torsten

    (@knodderdachs)


    Hi Nikel,

    I enabled the cookie banner and it seems to work just fine at the frontend of my website.

    But on the backend, the notice gets displayed every time I click on my website in the admin bar. Even if I accept cookies by clicking on the button. I checked if the cookie gets set correctly (yup, gets set correctly). But as soon as I switch back to the admin dashboard and then to the website, the cookie is gone and the cookie banner gets displayed again.

    This happens in Chrome, Vivaldi and Firefox. I also tried the mobile versions of Chrome and Firefox.

    If I only access the frontend of my website, everything seems to work. But as soon as I switch to the dashboard – by clicking on the button in the admin toolbar – and back to the frontend, the cookie banner shows up.

    What could I do to fix that?

    All the best
    Torsten

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Nikel Schubert

    (@nikelschubert)

    Hi,

    does it show up on all admin pages or only if you are on the settings page for the plugin.

    It should only show up if you are on the settings page of the plugin. On all other pages it should not be there.
    You can deactivate it by unchecking “preview banner” on General Settings Tab.

    If you see the banner on all pages it would be really great to know your installed WP Version and all other plugins you have installed.

    Regards
    Nikel

    Plugin Author Nikel Schubert

    (@nikelschubert)

    small addition: always when you are in admin area the cookie status gets deleted and you see the banner again in the frontend. This happens only to users who visit the admin area.

    Thread Starter Torsten

    (@knodderdachs)

    Hi,

    yes, the cookie gets only deleted when I visit the admin area.

    Yes, in preview mode, the banner only gets displayed on the settings page and not on any other page. That’s not my problem. I disabled the preview mode as soon as I was satisfied with the displayed banner. That’s all OK.

    The cookieconsent_status cookie (and only this one) gets only deleted while switching from the frontend to the backend area using the admin toolbar (that one on top of the screen) of WordPress. I run the latest version (5.2.2) of WordPress.

    I’ll send you an email in a minute with a list of my other installed WordPress plugins (don’t like to have them all displayed in this public thread).

    All the best
    Torsten

    Plugin Author Nikel Schubert

    (@nikelschubert)

    Hi @knodderdachs,

    should be fixed now. Just update to the newest version.

    Regards
    Nikel

    Thread Starter Torsten

    (@knodderdachs)

    Hey @nikelschubert,

    yup, works!

    Thanks and all the best
    Torsten

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Cookie Notice shows up every time when logged in as admin’ is closed to new replies.