• Resolved c.walter

    (@cwalterpas-solutionsch)


    We have a page in German an English (with WPML). With the Plugin Complianz (free version), a cookie notice page is created automatically (with the shortcode [cmplz-document type=\”cookie-statement\” region=\”eu\”]). When I create a duplicate of the page like stated here (https://complianz.io/translate-legal-documents-to-multiple-languages-with-wpml/), the cookie notice text in is German in both languages. Do I have to do this without the shortcode? The problem is, I don’t see any Gutenberg-Blocks from Complianz that I could choose for the cookie text.

    Regards
    Christoph

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @cwalterpas-solutionsch,

    The plugin is default in English, the rest are translations. These are the 2 Complianz blocks available: https://snipboard.io/VAtzWO.jpg

    I expect the default language is German, with an English translation? Is this page situated on a URL e.g. yourdomain.com/en/cookie-policy? This is the preferred option.

    regards Aert

    Thread Starter c.walter

    (@cwalterpas-solutionsch)

    Hello Aert

    Thanks for your feedback. The problem is – I have no Complianz blocks available (so I can only use the shortcode): https://snipboard.io/vUibWC.jpg

    The default language is German with an Englisch translation, yes. And yes, in German the Url is /cookie-richtlinie-eu/ and in English it is /en/cookie-policy/. But the content shows German in both languages.

    Regards Christoph

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @cwalterpas-solutionsch,

    Using the shortcode and translating the content with WPML should work fine as well.

    But if the content remains in German in both cases, that would appear to indicate some configuration issue with the languages in WPML. That’s the first thing I’d recommend checking for.

    It would be challenging for me to determine the exact configuration that causes this behavior on your environment, without knowing all the details about the set-up though. I’d say that the WPML support team would be best equipped to help you correct the language configuration in their plugin.

    Kind regards, Jarno

    Hi, I have exactly the same problem… @cwalterpas-solutionsch did you solve your problem?

    Thread Starter c.walter

    (@cwalterpas-solutionsch)

    No, I haven’t solved the problem. I first (before I posted the problem here) checked it with the WPML Support – the answer was:

    ich glaube, es wäre einfacher, wenn Sie den Complianz Support fragen, warum bei Ihrer Installation ein Shortcode eingefügt wird. Dies stimmt nicht mit deren Doku überein und lässt sich auch nicht isoliert reproduzieren. Da es bereit in Complianz falsch angelegt wird, kann ich hier keinen Fehler von WPML bestätigen.

    So, I don’t know what to do next…
    Regards Christoph

    • This reply was modified 7 months, 2 weeks ago by c.walter.
    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @cwalterpas-solutionsch and @dindludovic,

    Please know that we are of course glad to assist, but it seems that we are unable to replicate the described behavior with the latest versions of WPML and Complianz.

    I’ve installed both WPML and Complianz (latest versions) on a fresh WordPress environment and started with German (Sie) as the Site Language, and configured English as the second language in WPML.

    I then completed the Complianz Wizard, had the plugin generate the German document(s) and proceeded to create an English variant; all of which worked without similar issues appearing. It works both with the Gutenberg block, but also when using the Cookie Policy shortcode instead: [cmplz-document type="cookie-statement" region="eu"]

    If there are any further leads as to the differences between our environments (active theme, plugins) that might be related to the issue, please share these here and we’d happily investigate further.

    Kind regards, Jarno

    • This reply was modified 7 months, 2 weeks ago by jarnovos.
    • This reply was modified 7 months, 2 weeks ago by jarnovos.

    For my part, I use French instead of German. When I want to translate elements in WPML, the French text is displayed instead of the English. As a result, I can’t change the English text. https://snipboard.io/xLjf4T.jpg

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @dindludovic,

    That seems to be different issue than what the original poster of this thread experienced.

    In your case, you can navigate to WPML -> String Translations and use the Languages of domains option/link to switch the complianz text domain to the correct language (French).

    Kind regards, Jarno

    Thank’s for your answer ! @jarnovos

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @cwalterpas-solutionsch,

    If you still require a closer look at your issue, please contact us via support(at)complianz.io and we would be glad to do so. As we can’t seem to replicate the described issue on our end, that makes it a bit more challenging in this case.

    Kind regards, Jarno

    Thread Starter c.walter

    (@cwalterpas-solutionsch)

    Thanks Jarno – I wrote an email.
    Regards, Christoph

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cookie Notice not translated’ is closed to new replies.