Support » Plugin: Cookie Law Info » Cookie Law info clash with jsquery lightbox

  • Resolved n8steve


    Hi. Love the plugin which I implemented a couple of days ago on my church’s site Not just the plugin but also the examples of privacy policy statements etc.

    However, I found it clashed with jsquery lightbox when I posted a gallery from a recent event so have had to switch it i.e. Cookie Law Info, off again – dooh!

    The image clicked on appears as in lightbox but without the arrows allowing you to progress through the gallery etc.

    I use a theme called Ashford Pro which has its own plugin to add lightbox to the theme.

    As a coding numpty who tries to avoid looking under the bonnet of WP, I don’t who where to start other than to ask if you can advise please.

    Thanks. Steve

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Richard



    This will inevitably be your theme or another plugin causing this issue. It’s a recurring theme over the lifetime of this plugin but 99% of the time it’s nothing to do with Cookie Law Info.

    You will need some tech skills to correctly diagnose and fix it though. There is more info at or other posts on the forum which address this issue.

    All the best


    As the problem appeared when I activated CLI and went away when I deactivated the plugin, it seemed a sensible place to start.

    However, following your reply I carried on googling and found this:

    “You need to check your theme’s header and footer code. This code can be placed in any of the theme’s PHP files but most likely will be placed in the header.php and footer.php files in your theme directory. Make sure that both <?php wp_head(); ?> and <?php wp_footer(); ?> are being called.

    <?php wp_head(); ?> should be placed the line before the end head tag, </head>.

    <?php wp_footer(); ?> should be placed the line before the end body tag, </body>.

    Make sure both PHP function calls are in the appropriate place of your theme code and reload the page, the LightBox effect should now work.”

    I found that the line ‘<?php wp_footer(); ?>’ wasn’t immediately before ‘</body>’

    I changed it and now things all work – well so far they all appear to!

    I thought it worth publishing this back here in case it helps someone else!



    Plugin Author Richard


    Hi Steve- good detective work, and thanks for posting the solution! It’s a common problem that themes do this. Thanks, Richard

    Hi Richard,

    I also found out that my lightbox plugin stoped working after I installed CLI, took me a few days to find out it had stoped working, and a couple more to notice that deactivating CLI fixed it.

    When I activate CLI, clicking on any image will link to the post where the image is; it will not open the image, it will not show it with lightbox. Disabling CLI makes the lightbox work again.

    I am using WordPress v3.6.1, Simple Lightbox v2.1 and Cookie Law Info v1.1.2. I tried disabling all plugins except CLI and Lightbox, with same results. I tried from IE, Firefox and Chrome with same results. I tried with the theme I usually use (Graphene), and also with themes 2011 2012 and 2013. I checked <?php wp_head(); ?> and <?php wp_footer(); ?> as stated above, and they are correctly placed.

    Any hints would be appreciated, thanks!

    Plugin Author Richard



    Without a URL I can’t check anything, however the lightbox plugin you mention will almost certainly be hard-coding a javascript which is should not be doing. Instead it should use wp_enqueue_script(). It is something you should raise with the author of that plugin.

    Hope that helps,

    My bad, I thought that a click on my profile would lead to my WP blog or something. In case you want to check it out it is Securamente.

    Right now I have Lightbox enabled and working, but if I enable CLI it does not work any more. I will notify the author of Simple Lightbox about the wp_enqueue_script() thing.


    @richardashby: Actually, the issue was due to a “jQuery.cookie is not a function” error in CLI’s cookielawinfo.js file.

    While the issue may be due to a corrupted or missing file, it is a recommended practice to make sure that the object is available before attempting to invoke it, especially if it’s a non-standard dependency (like a jQuery plugin).

    More info here:

    I uninstalled CLI, made sure /wp-content/plugins/cookie-law-info was gone, and installed again v1.1.2 from scratch. Same results, SLB does not work when CLI is enabled.

    I have them both enabled now on the live site, so the issue can be seen.

    Yes, there’s something else going on there. The jquery.cookie.js file appears to be present in CLI’s plugin directory, but it is returning a 404 (page not found) error.

    This could be due to something else that affects URI handling such as another plugin or the site’s server configuration. Since the test site worked with only those SLB and CLI activated, the URI handling may be affected by another plugin that is activated on the live site.

    See Troubleshooting Plugin Conflicts for details on identifying the naughty plugin (or theme).

    With ALL plugins disabled (except SLB and CLI) on the live site, the results were exactly the same. I will see if I can dog into it a bit more, thanks for your time!

    Plugin Author Richard



    @archetyped thanks for looking into this. I should know better than to presume the cause of a bug before looking at a URL 🙂

    Maybe this issue is related:

    I’m away at the moment and not able to check in detail, but this might be related to the 404


Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cookie Law info clash with jsquery lightbox’ is closed to new replies.