WordPress.org

Forums

[closed] Cookie Error when Logging In (117 posts)

  1. amsgator
    Member
    Posted 1 year ago #

    I just visited http://www.maiscashback.com/ and I'm not getting a cookie from http://www.maiscashback.com/ or http://maiscashback.com/ in firefox. Strange

  2. Cam
    Member
    Posted 1 year ago #

    @amsgator, did you visit the wp-login.php on his site. I don't think he ever got my //fix code activated because the mu-plugin folder wasn't in wp-content.

    The test-cookie gets set when you try to visit the login page by default.

  3. willem.deboer
    Member
    Posted 1 year ago #

    It's not browser-specific in my case. Only difference is that IE v11 and Firefox convert to http://www.CNAME and Chrome does not.

  4. amsgator
    Member
    Posted 1 year ago #

    No I didn't visit the login page. When I visit the homepage of my site it sets a cookie so I figured his would too. I don't have any fix going on my site other than the .htaccess redirect I posted.

    When I visited the his login page it did set the cookie for me as well.

  5. amsgator
    Member
    Posted 1 year ago #

    @willem.deboer When I visit http://www.communsense.nl/ it sets the cookie for me so I'm not sure why it's not for you.

    I'm not sure what plugins you have running because you've got something running on your login page requiring the captcha. Disable all of your plugins and then try to login. There may be a plugin that is causing the issue.

  6. Cam
    Member
    Posted 1 year ago #

    @willem.deboer When I visit your site, the test cookie is set properly. It uses http://www.communsense.nl as the domain name.

    I visited your login page, and it appears as though you have a plugin or two customizing it. Have you tried temporarily deactivating the plugins that are making the adjustments to your wp-login.php and seeing if that makes a difference?

    ~Cam

  7. willem.deboer
    Member
    Posted 1 year ago #

    I just added the cookie-fix.php 5 minutes ago :-). It doesn't work for me though.

  8. Cam
    Member
    Posted 1 year ago #

    ditto to @amsgator :)

  9. amsgator
    Member
    Posted 1 year ago #

    @willem.deboer if you cannot login to disable them in your dashboard just rename all of your plugin folders so they are not recognized by WordPress

  10. willem.deboer
    Member
    Posted 1 year ago #

    OK. I don't get the "cookies disabled" message anymore with cookie-fix in place. Now it's the blank screen I end up in.

  11. willem.deboer
    Member
    Posted 1 year ago #

    I'll disable the plugins next.

  12. Cam
    Member
    Posted 1 year ago #

    @willem.deboer Do you have these lines commented out in wp-login:

    //	if ( isset($_POST['testcookie']) && empty($_COOKIE[TEST_COOKIE]) )
    //		$user = new WP_Error('test_cookie', __("<strong>ERROR</strong>: Cookies are blocked or not supported by your browser. You must <a href='http://www.google.com/cookies.html'>enable cookies</a> to use WordPress."));
    //	else
    		$user = wp_signon('', $secure_cookie);

    If so, that might be causing a problem, because without a cookie set for you, WP won't know what to do.

    ~Cam

  13. willem.deboer
    Member
    Posted 1 year ago #

    Plugins disabled, no joy. The blank screen always stops after GETting gmail.css(?) even when plugins are disabled.

  14. willem.deboer
    Member
    Posted 1 year ago #

    @cam, OK, I didn't get that. Tx.

  15. amsgator
    Member
    Posted 1 year ago #

    I don't understand where gmail.css is coming from...

    If it is from a plugin, delete your cache and then try again

  16. willem.deboer
    Member
    Posted 1 year ago #

    I've done that many times now. I don't get it either. I disbled plugins, commented out line 744 - 746 in wp-login.php and created cookie-fix.php and still it stops at gmail.css. Chrome is the only one with a debugger of sorts, but it doesn't work with IE11 or Firefoz either. And yet I feel I'm almost there.

  17. amsgator
    Member
    Posted 1 year ago #

    If you have cPanel, login to your cPanel and open the file manager inside cPanel. At the top right corner there is a search box. Search for gmail.css and see if that file is on your server and if so what it is related to

    Possibly your google translate widget?

  18. Cam
    Member
    Posted 1 year ago #

    @willem.deboer, using firefox, go to your wp-login.php page (or your home page) and then do the following:
    1. Press Shift+F2 to bring up the Developer toolbar.
    2. Type in: cookie list
    3. Press enter, and look for a test cookie (or any cookie) from your site.

    Let us know what happens.
    ~Cam

  19. willem.deboer
    Member
    Posted 1 year ago #

    @Cam Thank you. No cookies found ....

  20. amsgator
    Member
    Posted 1 year ago #

  21. Cam
    Member
    Posted 1 year ago #

    @willem.deboer -- Hmmm. That would be a significant problem.

    Something is blocking your cookies. Do you have any adware blocking programs on your computer that would stop cookies before they even reach your browser?

    ~Cam

  22. willem.deboer
    Member
    Posted 1 year ago #

    @amsgator yes they are. If I go to linkedin.com there's a whole bunch of cookies set.

  23. willem.deboer
    Member
    Posted 1 year ago #

    @Cam not that I know of. Spybot search & destroy and Windows Defender. I'm on Windows 8.1, by the way. And LinkedIn cookies are coming through fine, it appears.

  24. Cam
    Member
    Posted 1 year ago #

  25. amsgator
    Member
    Posted 1 year ago #

    That's weird... I'm stumped

    I gotta go, it's my bedtime. I'll check back when I wake up and hopefully you get it working. Good luck!

  26. Cam
    Member
    Posted 1 year ago #

    @amsgator I'm close to stumped too. :)

  27. willem.deboer
    Member
    Posted 1 year ago #

    That makes three of us :-) Thank you all for the help, sorry to be such a nuisance .... Sleep well!

  28. Cam
    Member
    Posted 1 year ago #

    @willem.deboer were you able to add an exception? If so, did that work?
    And, have you set to "Accept 3rd party cookies"? (not needed for the test cookie, but I am curious if something else is at work on your system.)

    Other things to test.
    1. Does it work with another computer, but still at your home?
    2. Or another computer (at work or at a friends house)?

    While unlikely, I wonder if something in your host is blocking cookies for just your site. I would have no way to test this, and I haven't heard of it happening, but it's about the only thing I have left that I can think of.

  29. willem.deboer
    Member
    Posted 1 year ago #

    No exception present. It does not work on any computer at home. All end with the blank screen. I used my Android phone to test what happens outside my own network (wifi off :-), no joy either. I have the funny feeling this gmail.css is the clue, but no idea where it comes from. I searched my webspace and my local computer.
    It's a pain. I just received new artwork and I cannot edit my pages to put it in. Nor update plugins, theme or WordPress itself.

  30. Cam
    Member
    Posted 1 year ago #

    @willem.deboer -- Looking back through the thread, I have one last idea before having to take off for my day:

    It appeared that the white screen started when you added @mirajas code into your functions of your theme file. If it is still there, I would remove it since it duplicates my mu-plugin fix, which you said you had applied.

    Beyond this, check if your webhost has backups, and revert your site (files) to 2 weeks ago (before any of these edits). If it is still broken, check for cookies being placed (especially on the wp-login.php page). If nothing is placed, then you could try reinstalling WP over itself (except for the wp-content folder) and see if anything else was change inadvertently.

    If all this doesn't work, I will be officially stumped. :)
    ~Cam

Topic Closed

This topic has been closed to new replies.

About this Topic