Support » Plugin: W3 Total Cache » Cookie doesn’t set with page cache

  • Resolved gennymac

    (@gennymac)


    Dear all,
    finally after some days i solved an issue who was struggling me.

    I setcookie inside a page to identify an user.

    With w3 total cache / page cache activated it works the first time than it doesn’t work more.

    I tried everything to set cookie disabling inside w3 total cache but it doesn’t work.

    the only solution that works is to unflag page cache and remain db cache and browser cache enabled.

    How could i solve this issue?

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @gennymac

    I am sorry about the issue you are experiencing and I am happy to assist you with this.
    Can you please share more details on what you are trying to achieve and what is the specific issue you are encountering?
    IS the Page Cache enabled for logged in users?
    Have you tried using the Cookie Groups and assign a set of Cookies to ensure that a unique cache is created for each Cookie group?
    Thanks!

    Thread Starter gennymac

    (@gennymac)

    the cookie when an user visit a page didn’t set

    now i had to remove page cache.

    How could i solve this issue? Thanks

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @gennymac

    Thank you for the information.
    Can you please share how did you set a cookie? Have you used any plugin or similar?
    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cookie doesn’t set with page cache’ is closed to new replies.