Support » Plugin: Complianz | GDPR Cookie Consent » Cookie Consent doesn’t show on front end after update

  • Resolved Alex Hamstra

    (@alex-hamstra)


    Hi,

    After updating to version 3.0.0. and going through the wizard again the cookie consent notice and settings tab are not showing at the front end. Clearing website and browser cache did not help either. This applies to 3 different sites.

    Kind regards,

    Alex Hamstra

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi @alex-hamstra,

    Could you share your URL with us so we can have a look? If you want you can log a support ticket, we might need more than just an URL to know what’s going on,

    Regards Aert

    No problem! URL: https://www.blikopfestivals.nl/en/

    This is the English version of the site (separate installation), I rolled back the plugin on the Dutch version, so there it works again.

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi @alex-hamstra,

    Will let you know!

    Groeten Aert

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi @alex-hamstra,

    We changed the cookie banner settings to opt-in/opt-out, instead of returning the specific region.

    The server returns the new settings, but because of server caching the return is not recognized yet. Are you able to purge the cache on the server?

    Could you also let me know if there’s specific caching on the server?

    Regards Aert

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    In addition to Aert’s response: the issue is that your server is still returning the 2.1.8 javascript file.

    The plugin adds a version the javascript file to prevent this, but on your server this is stripped off, preventing the refresh. In addition to this, the server is hard caching the file. This causes an inconsistency between the data the site receives from the server, and what the script expects.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @alex-hamstra,

    Looking at the URL of the javascript:
    https://blikopfestivalsen-289e.kxcdn.com/wp-content/plugins/complianz-gdpr/core/assets/js/cookieconfig.min.js

    I noticed the URL is from a CDN provider. This is probably the cause of the issue: your CDN is still serving the old file.

    As long as the string “EU, opt-in” is in the source, it is the old file, and the banner won’t show. The new file will only have “opt-in” in the source.

    Clearing your CDN, or temporarily deactivating it, will fix your issue.

    Hello Rogier,

    I did have the same problem as Alex. I disabled the plugin autooptimize. Now it works partially. The cookie consent is back but the problems with youtube video’s start to arise again.

    The website bastiaanvinke.nl

    Love the plugin..

    Fijne Koningsdag!

    • This reply was modified 1 month, 3 weeks ago by  bartjansen.
    • This reply was modified 1 month, 3 weeks ago by  bartjansen.
    Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi @bartjansen,

    I made a quick duplicate of your configuration, see below

    I have made a post, and embedded a YouTube block, with Gutenberg and Super Socializer

    http://zany-ratel.w6.wpsandbox.pro/2017/03/09/hello-world/

    I have deselected the following under javascript options. (Auto Optimize) Could you give that a try?

    Aggregate all linked JS-files to have them loaded non-render blocking? If this option is off, the individual JS-files will remain in place but will be minified.

    • This reply was modified 1 month, 3 weeks ago by  Aert Hulsebos. Reason: More specific

    Hello Aert,

    either my English is failing or my understanding of programming. Your duplicate is good. What I thought I had to do is to uncheck my Javascript code (autooptimize). The banner is visible with the plugin turned on but the YT problem stil exists.

    Forgive me if I haven’t understood you correctly.

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hoi @bartjansen,

    Normaal doen we het in Engels voor de community. Ik zal de oplossing straks vertalen. Ik zag dat Jetpack een tool heeft voor responsive video. Ik ga even kijken of ik dit kan nabootsen.

    Ben zo weer terug!

    Groet Aert

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    @bartjansen,

    http://zany-ratel.w6.wpsandbox.pro/2017/03/09/hello-world/

    Dit is hem. We gaan nu kijken.

    Groet Aert

    Thanks!

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    @bartjansen,

    Het lijkt erop dat Jetpack zijn eigen video responsive embedding boven op de geïntegreerde Gutenberg responsive blokken zet. Dit zorgt voor problemen.

    Kan jij zien of je deze optie kan uitvinken in Jetpack, ben er niet heel bekend mee, misschien zie ik het over het hoofd.

    Groet Aert

    Plugin Support Aert Hulsebos

    (@aahulsebos)

    Hi @bartjansen,

    On Git we have a new version which disables the Jetpack functionality of responsiveness. It doubles with Gutenberg and we don’t really know why.

    https://github.com/rlankhorst/complianz-gdpr

    This should fix the issue. Let me know!

    Regards Aert

    Hello Aert,

    unfortunately it didn’t fix the problem. At least my problem. Jetpack is indeed the main problem. When I turn it off it all works correctly.

    For now i keep it turned off (I can find other plugins that do the same trick) and keep on enjoying Complianz.

Viewing 15 replies - 1 through 15 (of 25 total)
  • You must be logged in to reply to this topic.