Support » Plugin: Google Analytics Germanized (GDPR / DSGVO) » Cookie bar won’t disappear after setting to ‘Disable’

  • Resolved kittykilian1

    (@kittykilian1)


    Hi,

    Great plugin. Neatly organized. Everything works great, except for the cookie bar. We don’t need a cookie bar in the Netherlands (yet). So I have set it to: disable. But whenever I log in in incognito mode, there it is. Also, after disabling it, it gets turned on again.

    So I gather other people still get to see it.

    Is this a plugin interaction or am I missing something?

    Thanks, Kitty

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Sascha Rudolph

    (@sascharudolph)

    Hey Kitty,

    probably there is another plugins which set it or you have a cache problem with your site. If you disable the cookie-consense function under “Tracking Settings” and save this, you are unable to see the banner, its not possible because we remove javascript and css, so there is no opportunity to make it visible. Please reCheck your site and make sure you don’t have the files in cache like (autoptimize, wp-super-cache or similar).

    Have a great day
    Sascha

    pro-tip; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there’s more info in the troubleshooting tips and info on exclusions in the AO FAQ.

    hope this helps debugging,
    frank (ao dev)

    Thanks, Sascha, that did the trick!
    But.. I need my site to be fast, so I need to cache. Is Frank offering a solution where I can still use the caching function?

    PS I really love the Grunlichkeit with which you have set it all up. Hope you get the plugin debugged further and I would not at all mind paying a few euros for a plugin that keeps working.

    Oops, Grundlichkeit, of course.

    Dag Kitty ๐Ÿ™‚

    Some questions to help you find a solution;

    1. Did you disable AO, WPSC or both?
    2. if both, do things work if you have AO on and WPSC off?
    3. if not, have you tried narrowing it down by disabling just AO’s CSS or JS-optimization?
    4. have you then tried excluding the “Google Analytics Germanized (GDPR / DSGVO)” CSS or JS from autoptimization?

    If not, that’s what you could try ๐Ÿ˜‰

    Groeten uit het zonnige Belgiรซ,
    frank

    Hi Frank,

    Thanks so much, but I just emailed my programmer to ask him to look into it. I have referred him to this page. I am afraid this is a bit above me. Were I to live my life again, I would learn to program rightaway!

    Thanks, and greetings from overly sunny Neerpelt ๐Ÿ˜˜

    Kitty

    Plugin Author PascalBajorat

    (@pascalbajorat)

    Thx @futtta for your support here.

    I will close this ticket for the moment, if there is anything new, please reopen it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cookie bar won’t disappear after setting to ‘Disable’’ is closed to new replies.