Support » Fixing WordPress » "Convert emoticons such as :-) and :-P to graphics on display" not available

  • Hello everyone.

    As the title says, the option “Convert emoticons such as ๐Ÿ™‚ and ๐Ÿ˜› to graphics on display” is not available to me. I search for a “change feature” from the new version, but it is still up, like described here:
    https://codex.wordpress.org/Settings_Writing_Screen

    I Deactivated all my plugins, but it didnยดt work as well.
    Any thoughts?

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • So under dashboard, settings, writing it is not there?

    You should try the default theme to make sure it is not a theme issue. You can also post at https://wordpress.org/support/theme/sparkling

    I had the same problem. It’s only occurring when you have a fresh install in a new database. I assume you are looking for it because you want to UNcheck the box there that is normally checked by default. I don’t like the text emoticons to be changed, so it’s usually the first thing I do is uncheck that box. Frustrating that it just disappeared!

    Here’s how to fix it:

    Simply log into your dashboard, then navigate to /wp-admin/options.php

    You will see ALL of your WP options listed there. Search for the “use_smilies” setting. You’ll see it is set at “1”. Change the “1” to a “0” (zero), then hit the “save settings” button at the bottom of the page.

    Just happened to read this thread. Never knew about the options.php page by itself. Lot of options left over from no longer used plugins.

    Hello Geek Goddess, thanks for your answer, it worked perfectly. I also opened it in a FTP client, where I could found this:

    if ( get_site_option( ‘initial_db_version’ ) < 32453 ) {
    $whitelist_options[‘writing’][] = ‘use_smilies’;
    $whitelist_options[‘writing’][] = ‘use_balanceTags’;
    }

    My DB is very new so maybe this is the main cause, as you said.

    By the way, Hello kmessinger, thanks for your answer too.

    That’s actually all over the code since sometime last month (ie. there are a lot of places where it is checking the database version and it’s always that same version). So, something changed globally. I think it had to do with when they added in emojis, they tried to take out support for the old smilies. Unfortunately, they also ended up removing the option to stop the substitution of text emoticons for image versions! ๐Ÿ™‚

    I’m hoping they’re going to see this as a bug and change it for a future release. In the meantime, editing the options will give us the ability to still set that without editing any of the core pages.

    I just reported this as a bug in case it hadn’t been reported yet. ๐Ÿ™‚

    Same problem in WordPress 4.4.
    New localhost test install with new database.
    the two options

    Convert emoticons like ๐Ÿ™‚ and ๐Ÿ˜› to graphics on display
    WordPress should correct invalidly nested XHTML automatically

    Are missing.

    Found Geek Goddess bug report https://core.trac.wordpress.org/ticket/34773 looks like we are stuck with it ๐Ÿ™

    It’s interesting that WordPress core are forcing these types of things on users with no “easy” built in way to disable them. Smileys on by default, Emojis on by default, json-api on by default…. With Google taking pagespeed into account having all this extra bloat is not good for users!

    David

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘"Convert emoticons such as :-) and :-P to graphics on display" not available’ is closed to new replies.