Support » Plugin: Google Tag Manager for WordPress » Conversion value is always 0 despite proper setup

  • Hello Thomas,

    All my conversions have 0 value.
    Image from Gyazo

    I did a proper setup for a variable for the site tag and in Tag Managet debug view everything is fine, however, it is displayed as 0 in tag assistant.
    Image from Gyazo

    Could you give me a hint on what may cause this, please?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • I am having this same exact issue. I have tried multiple avenues to try and fix it and it has been flat-lined since November 5th. Traffic statistics and goals are working properly but there is no revenue or transactions being recorded.

    Plugin Author Thomas Geiger

    (@duracelltomi)

    Hi @a1tair,

    Thanks for posting this detailed description.

    According to your screenshot your the “Conversion Value” shows the value of 1. Was this the correct value? I can not see any product with the price of €1 on your site. Perhaps you were using a coupon code?

    You should double check the conversion ID value as this is more like an account ID in Google Ads, all conversions and remarketing tags use the same ID within a Google Ads account. If this is setup incorrectly (for example if just one number is missing) you will see that the data is being send but not received in your Google Ads account. The same applies for your Conversion label option but this time the label has a specific value for each conversion action in your account.

    @jpattwell – the report of @a1tair is about the Google Ads conversion tag. Based on your comment, you have issues within your Google Analytics property. If this is the case than you do not have the same exact issue.

    a1tair

    (@a1tair)

    @duracelltomi I’ve temporarily changed the value of one of the products to 1GBP to test the purchase.

    I’ve checked all the IDs and everything is fine. What else could it be?

    I’ve created a test product for you if you would like to check the firing of conversion tag https://marigru.studio/product/nothing/ but its value is 0.

    • This reply was modified 2 months ago by a1tair.
    a1tair

    (@a1tair)

    @duracelltomi I’ve changed the Conversion Value in Conversion Tag from Variable
    Image from Gyazo
    Image from Gyazo

    To a static number
    Image from Gyazo

    And Tag Assistant fired with the proper Conversion Value
    Image from Gyazo

    Does that mean that my setup is valid, and the reason is either in Google Tag Manager Plugin or something on the website that interfere with it?

    Plugin Author Thomas Geiger

    (@duracelltomi)

    Ff Google Tag Assistant shows the correct conversion ID, label and value than the data is sent since Google Tag Assistant is catching the network request regardless of whether it is fired through Google Tag Manager or directly from the website.

    What I missed is that you have checked this on the conversions page in Google Ads but in Google Ads you will only see counts and values happening through ads clicks meaning that you need a running campaign, a real paid click and then a tracked conversion to see any data within Google Ads

    a1tair

    (@a1tair)

    @duracelltomi is Data Layer Version 1 or Version 2 used in the Google Tag Manager Plugin?

    Plugin Author Thomas Geiger

    (@duracelltomi)

    Version 2 should be use which is also the default selected if you are creating a new variable. Version 1 is only for very specific and rare cases.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.