Support » Plugin: Multisite Language Switcher » Controlling where the flags show up

  • This may be a dumb question, but I can’t figure out how to control where the flags show up.
    They automatically show up on my homepage, under the title of each post (on both the post itself and on the archive pages).
    I just read about the ability to add to the menu with the other plugin MSLS Menu – which is great and I’d love to try it, but I’d like to get rid of all of the other places where the flag is automatically showing up. It makes my website looked cluttered.

    I must have figured it out long ago because I got rid of it in a lot of places, but I just switched themes and now I have the problem again.
    Thanks in advance for any guidance!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Dennis Ploetner

    (@realloc)

    Yes, you can do that. I assume that you are using the widget or that you put some PHP code in a template, did you? Just remove that and use the addon for the menu. In my opinion, MslsMenu (https://it.wordpress.org/plugins/mslsmenu/) is the better choice in your case and maybe the widget in the footer could also be a good idea.

    Let me know if this was helpful or if you need more information.

    Cheers,
    Dennis

    As far as I can tell, I only have a widget set up in the sidebar, but I’m getting the flags all over the place.
    I can try to set up the menu and see what happens. I just didn’t want to add yet one more flag when I already have so many up already!

    Plugin Author Dennis Ploetner

    (@realloc)

    Did you activate something else in the plugin’s settings?

    To be honest, I have no idea. I set it up so long ago, and now I’m looking at the settings and don’t really understand them.

    I don’t see anything, though- other than hint priority 10.
    I don’t know what that means. Maybe I’m not looking in the right place?

    Oh wait- I took somethig off this morning, but it didn’t seem to make any changes, but now they have disappeared.
    It must have been the cache!

    OK- I have to run, but tomorrow I’ll add the menu and let you know how it goes.
    Thank you so much for your help so far!

    I installed the menu plugin and it works wonderfully!
    Everything else worked itself out too. The issues I was having must have just had to do with the cache.
    I do wish I could center the flag on my menu, though. I can look into solutions for that, but for now, I’m very happy!
    Thank you so much for your help.

    I think I shouted victory a bit too soon.
    I just realized that the post I was looking at didn’t have a translation which is why it wasn’t showing up under the title anymore.
    If I look at a post with a translation, I’m still getting the flag under the title and don’t want it to show up there!
    Any ideas?
    Here is an example post…
    https://thethingswellmake.com/how-to-make-a-captain-america-shield/

    I ended up hiring someone to fix it. He was also able to center the flag for me on the menu.
    Totally worth having someone who knows what they are doing give some help!

    Plugin Author Dennis Ploetner

    (@realloc)

    Good to read that you solved your problem with the styling.

    There is probably the option “Add hint for available translations” active. read on here:

    https://msls.co/user-docs/plugin-configuration.html#add-hint-for-available-translations

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.