Support » Plugin: Autoptimize » Controlling pages cached

  • Resolved EdinburghImages

    (@unconsultancy)


    Hi,

    I’m using Autoptimize & Autoptimize CriticalCSS.com Power-Up.

    WP Cache is enabled but I’m not using any other caching plugin apart from Autoptimize.

    The issue is that the forum plugin developer has told me that the forum pages should not be minified or cached as this interferes with some processes they need.

    Is it possible to exclude https://unretired.co.uk/forum/* from minification & caching?

    Tim

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    hey Tim;
    AO does not cache pages (HTML), so nothing to do there. If you want to avoid those pages being autoptimized you can use this code snippet;

    add_filter('autoptimize_filter_noptimize','noptimize_forum',10,0);
    function noptimize_forum() {
    	if (strpos($_SERVER['REQUEST_URI'],'forum/')!==false) {
    		return true;
    	} else {
    		return false;
    	}
    }

    That being said; main issue with the forum seems to be tinymce (the HTML editor) which can be fixed by having js/jquery/jquery.js,wp-includes/js/tinymce in the comma-separated JS optimization exclusion list 🙂

    hope this helps,
    frank

    Thanks.

    My bad as they say. I’d turned off a vital part in the forum plugin. Sorted!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’re welcome Tim, feel free to leave a review of the plugin and support here! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Controlling pages cached’ is closed to new replies.