Support » Plugin: Exit Notifier » Control which links get the notifier

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Curtis V. Schleich

    (@cvscvstechcom)

    Currently it’s only on or off. It will only apply to links not on the site the plugin is installed on. I’ll look at maybe adding regular expression matching for inclusion or exclusion. I’ll reply here again once I’ve looked at it.

    Thanks so much for the quick response and for looking into the request!!

    Take care!

    Plugin Author Curtis V. Schleich

    (@cvscvstechcom)

    Okay, give it a try. There’s now an option to use your own jQuery selector syntax to decide what gets the notifier. The field should have the default in it already. All you have to do is add the exception to the end of the default selector. For example if your wordpress installation in http://example.com, your default selector should be:

    a[href*="//"]:not([href*="example.com"])

    So, if the link you don’t want the exit notification on is google.com, you can simply add that exception to the end like this:

    a[href*="//"]:not([href*="example.com"]):not([href*="google.com"])

    Then no links containing google.com in the URL will have the notifier on it.

    Hope that helps!

    Curtis, you are the man!!! Thank you so much for looking into that issue for me. Works like a charm!!

    Have a fantastic day!!

    dnoble94

    (@dnoble94)

    I have unchecked “Apply to all offsite links”

    I have set the “jQuery Selector” to “a[href*=”//”]:not([href*=”www.mydomain.com”]):not([href*=”data.someotherdomain.com”])”

    But when I press save that test the site, we don’t get any exit notifiers at all for example when we click our link to facebook ?

    I’m having the opposite issue as dnoble94. I have unchecked “Apply to all offsite links”, I have set the “jQuery Selector” to a[href*=”//”]:not([href*=”http://camino.kwsmdesign.com/”]):not([href*=”https://onlinebanking.caminofcu.org/caminofederalcredituniononline_41/uux.aspx#/login”]), saved changes and the exit notifier is still showing up when I click on the login link at the top right of the header. According to the custom code, there should be no notification.

    http://camino.kwsmdesign.com/

    Plugin Author Curtis V. Schleich

    (@cvscvstechcom)

    Thanks, steve2017 for starting a fresh topic on this one. I’ll check in on you there.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Control which links get the notifier’ is closed to new replies.