Support » Requests and Feedback » Control Page Encoding in Options

  • Currently, wordpress.org hard codes the page encoding:
    “iso-8859-1”
    in no less than 18 places throughout all of its files (listed at the end of this email). This is not good for those of us who want to use UTF-8 or 2-byte Asian languages (e.g. CJKV)
    Please replace all of these with a single variable like $charset and either put this in one file that we can easily change, the database options, or preferably, included the ability to set this option directly in WordPress’s options.
    I recommend using UTF-8 as the default and resolving any problems such an encoding might create. It is long past time to move past Latin encoding. There is a whole world out there…

Viewing 8 replies - 1 through 8 (of 8 total)
  • Nick Momrik

    (@mtdewvirus)

    Has it been fixed in CVS yet when running upgrade.php? It gives the following error:
    SQL/DB Error:
    [You have an error in your SQL syntax near ‘http://developer.apple.com/documentation/macos8/TextIntlSvcs/TextEncodingConvers’ at line 1]
    INSERT INTO wp_options (option_id, option_name, option_type, option_value, option_description, option_admin_level) VALUES (93, ‘blog_charset’, 3, ‘utf-8’, ‘Your blog’s charset (here’s a list of possible charsets)’, 8)

    Moderator Matt Mullenweg

    (@matt)

    Yes that has been fixed.

    Nick Momrik

    (@mtdewvirus)

    I’m still getting it…

    philor

    (@philor)

    Yeah, I think MDV means the fix for the breakage because of your fix (look at your single quotes around the URL – they end the value), not your fix for the previous breakage.
    We need a Tinderbox/Bonsai setup 🙂

    Nick Momrik

    (@mtdewvirus)

    Yup, philor, that was the problem. I modified line 712 in upgrade-functions.php, adding \ before the ‘ around the URL and now it works. 🙂
    I should have stared at the code a little longer, maybe I would have eventually noticed it myself!

    michelv

    (@michelv)

    I fixed it (again… I’m sorry about this) an hour ago, but the anonymous CVS is slow to catch updates.

    philor

    (@philor)

    Sorry to keep nagging about the tiniest things, but install.php needs the same fix escaping those same troublesome quotes around the href.

    Has this issue been resolved?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Control Page Encoding in Options’ is closed to new replies.