• When I run redis-cli flushall , enable the plugin and select “Enable object cache”, a stream of continuous Redis reads and writes start. These are seemingly option, transient and post reads/writes. I let it run for 30 minutes, but the operations did not stop. These operations exhaust server resources rendering the plugin unusable. Any idea why this is happening or where to debug next?

    Status: Connected
    Filesystem: Writeable
    Redis: Reachable
    Max. TTL: 3600
    Connection
    Client:	PhpRedis (v5.3.7)
    Host: 127.0.0.1
    Port: 6379
    Database: 0
    Connection Timeout: 1s
    Read Timeout: 1s
    Redis Version: 5.0.14
    $ redis-cli --latency
    > min: 0, max: 4, avg: 0.19 (2853 samples)
    $ redis-cli info | pastebin
    > https://termbin.com/g7f8
    $ redis-benchmark -q | pastebin
    > https://termbin.com/e39k
Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi,

    What maxmemory and maxmemory policy do you use at redis.conf?

    MAX TTL 3600 (an hour) seems small

    What helped really my servers, was to disable presistence, with save “”

    at redis.conf, when is used only for caching persistance seems just reource consuming for nothing, maybe this setting will help you.

    Not an expert at topic but i use plugin at many servers with really big boost at performance, really thanks Till Krüss for this

    Plugin Author Till Krüss

    (@tillkruess)

    You might just need more resources for Redis Server.

    Can you flush the cache again, let it run for 2-3 minutes and post redis-cli info | pastebin again? I want to see the metrics under load with lead to the crash.

    Thread Starter Sakri Koskimies

    (@saggre)

    Thank you for the replies. This Redis instance is running with persistence disabled.

    This is after flushing cache and running for 3 minutes:

    $ redis-cli info | pastebin
    > https://termbin.com/4r3tc

    Maxmemory and maxmemory-policy configs:

    $ redis-cli CONFIG GET maxmemory
    > 1) "maxmemory"
    > 2) "0"
    $ redis-cli CONFIG GET maxmemory-policy
    > 1) "maxmemory-policy"
    > 2) "noeviction"
    Plugin Author Till Krüss

    (@tillkruess)

    instantaneous_ops_per_sec:641

    Your Redis version (5.0.14) is a bit old, but that won’t be a performance issue.

    Your memory consumption and settings look good.

    It looks like Redis Server is getting around 650 operations per second, which is a lot (depending on your hardware).

    What are the specs of the machine you’re running this on?

    We can take a closer look at your redis-cli monitor output later, but first I’d suggest using the Query Monitor plugin to see what’s causing the load.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.