[closed] Continuous redirects to /wp-admin/&reauth=1 (39 posts)

  1. remizyaka
    Posted 6 years ago #

    After clean installation of WP and Network enabled can't login into blog
    wp redirects me to
    after each login
    How can I solve this?

  2. Clear your cookies & your cache to start.

  3. remizyaka
    Posted 6 years ago #

    already tried
    also tried in other browsers
    without success :(

  4. Got any redirection plugins running?
    try disabling all your plugins.

    (I know the first post said a clean install, just checking)

  5. remizyaka
    Posted 6 years ago #

    all plugins disabled - it's really clean install

    maybe I can enable some logging to find out what is happening?
    have such redirects on every login
    wp-login.php -> network.php -> wp-login.php

  6. eduguytoo
    Posted 6 years ago #

    I have the same issue as posted in another topic, http://wordpress.org/support/topic/306956?replies=18#post-1579550

    Anyone ever figure anything out on this, Fresh install, not a plugin, not a browser issue, not a cache issue, not a cookie issue.

    Tried all browsers, all are the same this is PHP problem, If someone can point me to the right PHP page, to fix this I would be a very happy camper,

  7. I suspect your site is set up with a www and the network lines have a non-www reference.

  8. remizyaka
    Posted 6 years ago #

    don't have www in my site setup

  9. remizyaka
    Posted 6 years ago #

    finally found the solution
    on my test platform I had host wmpu-local without dot
    thats why when WP tried to set cookie for subdomains browser can't accept it
    because there was .wmpu-local host in set-cookie

  10. berteh
    Posted 6 years ago #

    Glad you fixed your problem.

    For future reference I had the same problem after setting the option "dashboard site" (Super Admin > Options > Dashboard Site) to a blog id.

    After having done so, any visit to my blog url would redirect me to dashboard authentication page.

    Resetting this option to blank solved the problem.

  11. masonjames
    Posted 6 years ago #

    I just went to redo an install on a development server today and am coming up with this exact error.

    The homepage loads just fine with twentyten installed. I can access the DB fine, but when I try to login through wp-login.php I get a redirect with "wp-admin%2F&reauth=1" at the end.

    Logging in with an incorrect username/password throw up the normal "screen shake" error and I can go through the password reset stuff as well, but a correct login sends you back to the login page each time.

    I've tried editing resetting the .htaccess back to the default and commenting out the WP_ALLOW_MULTISITE in wp_config but getting nowhere.

    Any other ideas?

  12. Cleared your cache & cookies? A different browser is always a good test.

  13. gazouteast
    Posted 6 years ago #

    Got this too after a 100% clean install last night

    All the tests etc above done - still don't work - exactly same symptoms as masonjames

    (for inter-user comparison - this one is on webhostingpad.com shared server PHP 5.2 MySql 5.summick Apache 2.summick install in domain root of an add-on domain, cPanel)

  14. masonjames
    Posted 6 years ago #

    gazouteast, was this a fresh install over top of an old install?

    Andrea_r's solution did work for me. I actually reset my .htaccess file to the "default" WordPress and then did a dns cache flush (open a terminal and type "dscacheutil -flushcache")

    Did the trick. I then enabled mutlisite and updated my .htaccess with the rules provided within WordPress. No issues. Running multisite on subdomains now.

    I thought it might be an issue with the host as it uses vDeck (which I'm not as familiar with as cPanel) but it's definitely a local cache issue. If you've cleared you're browser try a clearing the dns. Good luck!

  15. gazouteast
    Posted 6 years ago #

    Hi All

    Nope to all the suggestions above - the resolution was far simpler than all of you are looking at, and I'm very surprised Andrea didn't think of it (but then I didn't either and I have a long-standing bug report in trac about it).

    In WPMU 2.9.2 and earlier, the final screen of install is about 3 screen heights tall - at the top it gives the master admin username and password followed by a "login now" button. A LONG way down that page it says to delete or rename the /wp-admin/install.php file BEFORE trying to login.

    WP 3.0 does not have that warning anywhere in the install screens, nor the readme, nor anywhere in the codex. On a hunch, I tried doing exactly that - BINGO - got straight in.

    When I get a minute, I'll file another bug report in trac about this.

    Hope it helps you all

  16. daand
    Posted 5 years ago #

    I cleared Cache and cookies, but after some times it starts again..
    Does anyone know where this error is comming from so i can remove it?


  17. leivajd
    Posted 5 years ago #

    same problem here, I cleared cache and cookies ans still canĀ“t login

  18. Naturegirrrl
    Posted 5 years ago #

    same issue here

  19. Old Irving
    Posted 5 years ago #

    Same here - with a brand new site, brand new install, following all the instructions at http://codex.wordpress.org/Create_A_Network

    Background Info:

      Wordpress 3.0.1 on Dreamhost shared hosting
      PHP and MySQL updated to very recent versions (don't remember exact, but checked for Buddypress before starting this)
      pretty urls enabled just fine
      all plugins disabled before install begun
      database backed up before install begun


      Added line to config file using net2ftp webFTP editor (didn't download to computer)
      Chose subdirectories, not subdomains - and checked that site goes to domain.org, not http://www.domain.org
      Clicked on Install - never got to the "Enabling the Network" screen, it went straight to the login redirect loop (or just a redirect error on some browsers).


      Started with Chrome, so got advice on cookies & cache - cleared both, no difference
      Went to Firefox & Camino, no help
      Checked a different www.domain.org vs domain.org setting. Waited, didn't work, changed it back.
      Tried going to wp-admin/install.php and changing it to install-old.php. Didn't work.

    I'm just trying to get a site set up for a community organization, and I can see there may be good reasons to use multisite with subdirectories in the future. I don't necessarily want to set up a bunch of additional sites now, but I also don't want to lose the chance to use this tool.

    Here's the site, if anyone has any better luck: http://merchantparkcommunitygarden.org.

  20. WordPress 3.0.1 on Dreamhost shared hosting

    Check with them - they may require an upgraded plan.

    Also, if you've used their one-click wordpress installer , they add a bunch of junk to the bottom of the config file which has interfered with setups before.

  21. Old Irving
    Posted 5 years ago #

    Thanks, Andrea.

    I'd checked around on the Dreamhost forums and wiki before signing up with them, trying to see what the options would be for multisite. I found this conversation in the forums where you tried to confirm what restrictions they would put on multisite and one of their staff confirmed they would support subdirectories.

    What I didn't find online (though it may be there, I just didn't see it) is that it does indeed take a different type of subscription, a VPS (Virtual Private Server). It costs about $15 a month, according to this website: http://www.dreamhost.com/hosting-vps.html

    I wasn't planning on setting up multiple blogs right now, I just wanted to have the superadmin role and any database adjustments set up so I could possibly add that functionality in the future. I didn't like the sound of this:

    You cannot choose Sub-directory Install If your existing WordPress installation has been set up for more than a month, due to issues with existing permalinks.

    Alas, I guess I'll just have to cross that bridge when I come to it.

    Next challenge: removing the multisite option without bothering with a whole new installation. I may be back in these forums shortly with more questions.

  22. What I didn't find online (though it may be there, I just didn't see it) is that it does indeed take a different type of subscription, a VPS (Virtual Private Server). It costs about $15 a month, according to this website: http://www.dreamhost.com/hosting-vps.html

    That should only aply if you wanted subdomains, though I woudl not be surprised if they added some script to the server to muck up anyone trying to set up sobfolders as well. Cuz it can be more resource intensive because you're adding new blogs.

    The good news for you though, is you can really set this up any time.

  23. FYI, you can't choose it, but you CAN switch to it ;) It's a one line change, but it's not permitted out of the box so that only people who can understand they MIGHT goober permalinks make the change. Sort of a way to protect you from yourself.

  24. O Ofutur
    Posted 5 years ago #

    I've just experienced the looping problem and was using the domain mapping plugin on a WP Network setup.
    What solved it is to map the domain name even if it's already the main domain for the account.

    I registered user.mydomain.com and mapped cooldomain.com, but didn't want to leave it like that because some plugins use the main URL instead of the mapped one.
    So, I changed the main one to cooldomain.com and removed the mapped one.
    At that point, it's only possible to log into WordPress from the main dashboard, with the main account.
    Mapping cooldomain.com to cooldomain.com and marking it as the primary domain solved the problem.

    Just documenting in case it helps someone else.

  25. Litso
    Posted 5 years ago #

    I have the same problem, and I can't seem to solve it. It's a fresh install, I removed /wp-admin/install.php and installed domain mapping with the right settings..

    I fixed it by reverting the 'original' domain in the site's settings back from 'newdomain.com' to 'sub1.domain.com' but that causes all the files etc to be shown as sub1.domain.com, which I really don't want.

    I wasn't able to fix that with domain mapping so I really want to go back to using the newdomain.com as the site's base url.. any ideas?

  26. Did you check the "use remote login" ticky box under the domain mapping settings?

  27. Litso
    Posted 5 years ago #

    I've tried that, but when I use it while setting the site to sub1.domain.com that url stills shows up in the sourcecode. When I set the site to newdomain.com I get the redirect error.

    My domain mapping settings:
    Remote Login --Check
    Permanent redirect (better for your blogger's pagerank) --Check
    User domain mapping page --Nope
    Redirect administration pages to site's original domain (remote login disabled if this redirect is disabled) --Check
    Disable primary domain check. Sites will not redirect to one domain name. May cause duplicate content issues. --Nope

    And of course in domains settings I have added newdomain.com to the corresponding site id as a primary domain.

  28. Litso
    Posted 5 years ago #

    Ah, I found the problem. Apparently, my cookies are set at .www.mydomain.com (I force www, maybe it's time to stop doing that).

    Also, the path in there is /wpmu/, the folder in which my wordpress install is located. I have a htaccess rule that hides that path from my urls, and I've edited the wordpress htaccess and wp-config to reflect that (in other words, changed the path back to '/') but apparently the old path is still added to the cookie. Anyone know how to circumvent this?

  29. Litso
    Posted 5 years ago #

    Sorry for the multiple posts, I couldn't edit the one above anymore.. Anyway, I removed www and the problem still exists, so I think the problem is either in the path or something else completely. Any help is welcome.

  30. If you're trying to hide the folder it's installed in, that's why. you can't do that successfully.

    Also it's not wpmu any more.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.