Continued PermaLink Problem (12 posts)

  1. motoed
    Posted 11 years ago #

    I've had intermittent problems with WP Beta 1.5 for some time now. I have some sites that display pages no problem and other installs of the EXACT same version of Beta on the same server exhibits the same problem.

    I have a site that when I set a permalink structure, the site displays everything as "page not found" errors. I have copied the ModRewrite text to the htaccess file a couple times to be sure it's right... same problem.

    Now I'm having a problem with a site that's been working FINE with the permalink structure (www.edhidden.com) and that page shows as not found.

    But if you do the index.php?id=35 it'll show.

    This isn't the first time this has happened.

    Is there something I'm doing wrong?
    It seems like I must be, but I'm not sure what I could be doing wrong.

    Any input on this frustrating matter would be greatly appreciated!

  2. adsworth
    Posted 11 years ago #


    what version of apache are you running.
    I have found one version (2.0.51 I think) where I have problems with mod_rewrite. The problem arises when you have a rule that expects two variables one of which isn't set, in that case it silently fails todo the rewrite.
    ^/(.+)/?(.+)/?$ index.php?page_name=$1&feed=$2
    (that rule is untested, just to explain the problem)
    now if I just call /post-slug then the second parameter isn't filled and the rewrite doesn't happen. I need to add a new rewrite rule just before this one without the second parameter so it catches the request and processes it OK.

    I hope that gives you an idea and somewhere to start.


  3. motoed
    Posted 11 years ago #

    I'm running: Apache/1.3.33 Server

  4. motoed
    Posted 11 years ago #

    I must say... I didn't follow your reply. I'm somewhat of an apache/php newbie. I'm migrating from the wonderful world of ASP and Access. And right now my head is spinning with what I don't know!

  5. motoed
    Posted 11 years ago #


    I just followed another thread and was working with my .htaccess file and finally got the write access setup on it... and NOW it's working fine.

  6. Bonfire
    Posted 11 years ago #

    motoed, what did you do to solve the problem? i'm having the same issues...

  7. motoed
    Posted 11 years ago #

    Actually, I'm having the same problem still...

    I didn't have my .htaccess file set to the right permission. I thought I had fixed it. I can make a change to my permalink structure, then go in and everything is fine, but an hour later or so, pages are reporting as "not found".

    It's like the mod-rewrite rule is changing or something.

    Is this happening often?

  8. James Huff
    Support Representative
    Posted 11 years ago #

    Yes, the mod_rewrite rule changes whenever you change your permalinks.


  9. motoed
    Posted 11 years ago #


    I understand that. But if I change mine, it's ok.... then an hour or so later, the Permalinks are "broken" again.

  10. James Huff
    Support Representative
    Posted 11 years ago #

    Try this:
    1. Login to WP and navigate to Options/Permalinks
    2. Access your site via FTP and delete the .htaccess file.
    3. Change you permalinks.
    4. Put the new rewrite rules in a new .htaccess file and upload that.

    Also, what kind of permalink structure are you trying to use?

  11. motoed
    Posted 11 years ago #

    I tried to do this...

    I got up to #3 and then changed my permalinks, but didn't get the message "you don't an htaccess file" or "we coudn't update this automatically because of it wasn't writable" message. It just acted like the file was there.

    And it looks like it created a new htaccess file.

    The links appear to work now. I wonder if they will shortly though.

    (one last issue that MIGHT be causing problems... is my server provider has a web control panel where I'd made changes to my htaccess file in the past because my FTP program couldn't show hidden files. I wonder if that setting in the webcontrol panel is causing a "rewrite" of that file after a while that it realizes it's out of sequence?)

  12. James Huff
    Support Representative
    Posted 11 years ago #

    The better solution would be to get an FTP app which can show hidden files.

    If you're on a Mac:
    or http://cyberduck.ch/

    If you're on a PC:

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.