Support » Plugin: WooCommerce Stripe Payment Gateway » Continual Stripe Endpoint Error emails

  • Resolved pdelite

    (@pdelite)


    Hello,

    We have been continually getting these notices. The URL matches exactly what is in the Stripe account and there are no security plugins installed. Any suggestions?

    ———-

    We’re contacting you because we’re still having trouble delivering data to a webhook endpoint associated with your account in live mode. Webhooks are used to notify your server about events that happen in your Stripe account, such as a payout completing or an invoice being created.

    You or someone on your team has added that endpoint in your Stripe webhook settings, which you can view and edit here: https://dashboard.stripe.com/account/webhooks.

    Please note that in most cases a failing webhook does not impact your payments or payouts. However, if you use subscriptions we rely on your webhook endpoint to notify you of new invoices. These invoices may be delayed for up to three days if your webhook is unable to successfully receive them. If you use Checkout, you may be handling the checkout.session.completed event as part of your purchase fulfillment process as described here: https://stripe.com/docs/payments/checkout/fulfillment#webhooks. If you do, failure to handle these events may interfere with purchase fulfillment.

    We’ve attempted to notify the endpoint 21 times since May 20, 2020 at 03:47PM. If this endpoint is important to your application, please try and fix the issue. If you do not need the webhook endpoint you can delete it from your Stripe webhook settings. We will stop sending notifications to your webhook by May 29, 2020 around 03:47PM.

    Here is the summary of errors we have received when sending you webhooks:
    * 21 requests returned a HTTP 301, which usually signifies you need to update your webhook URL to point towards a new location.

    You need to return anything between a HTTP 200 to 299 for the webhook to be considered successfully delivered.
    For more details on the errors, you can find your events page here: https://dashboard.stripe.com/events.

Viewing 4 replies - 1 through 4 (of 4 total)
  • @pdelite i have the same problem, see it here…

    https://wordpress.org/support/topic/stripe-webhook-errors/

    Removing the webhook secret on the plug-in site fixed the issue, but i’m sure something is not right.

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @pdelite

    As @tgunergun mentioned, we’re looking into a similar issue in another thread.

    If you’re able to provide any and all conflict testing, that would really help us narrow down the cause for this!

    As a note, I have been unable to replicate this on my test sites.

    The only failures I receive are when a test site does not have the Stripe extension active but I’ve kept the webhook active in my Stripe.com account.

    If you’ve managed to resolve this another not by removing the webhook secret, please do reply back here to update us.

    Thanks,

    Plugin Support Joey – a11n

    (@jricketts4)

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    – Joey

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    One fix for this if everything is correct, please check the time settings for everything – As mentioned in the following post, the cause of the 400 error was a result of the incorrect timezone settings:

    https://wordpress.org/support/topic/stripe-webhook-errors/page/2/#post-12978711

    Thanks,

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Continual Stripe Endpoint Error emails’ is closed to new replies.