Support » Plugin: WP Mail Logging by MailPoet » contextual_help is deprecated since version 3.3.0

  • After updating to WordPress 5.4 i’m seeing the following message when debugging is enabled ;

    Deprecated: contextual_help is deprecated since version 3.3.0! Use get_current_screen()->add_help_tab(), get_current_screen()->remove_help_tab() instead. in /xxxx/wp-includes/functions.php on line 5088

    This is related to WP Mail Logging, it only happens when the plugin is active.

    FWPML_OptionsManager.php uses the variable $contextual_help.

    Line numbers 345, 396, 402 406 and 452 all have “contextual_help” in them. Replacing “contectual_help” with “wpmail_logging_contextual_help” fixes the error and the plugin seems to function as normal.

Viewing 15 replies - 16 through 30 (of 30 total)
  • I got same message after updating WordPress. I dont have WPmail so I’ve deactivated all of them. So when I’ve activate LayerSlider I got the message again. But Layer Slider also got update suddenly!
    Message has gone after I’ve updated Layer Slider…

    Unsubscribe.

    Just realized I was getting this error

    “contextual_help is deprecated since version 3.3.0”

    Used the following fix posted by @paulgooch

    Error is related to WP Mail Logging –
    First deactivated then reactivated the plugin to verify the error was associated with this plugin.

    Next went to the Plugins Editor within the WP Admin section and found the following file.

    FWPML_OptionsManager.php uses the variable $contextual_help.

    Used the Find feature in the plugin editor to locate each instance of the tag “contextual_help” and replaced them in the file with “wpmail_logging_contextual_help”

    This resolved the issue and error is no longer showing up.

    Thank you @paulgooch

    Replacing “contectual_help” with “wpmail_logging_contextual_help” worked for me no more errors

    Hey!

    I have the same error. And the described hotfixes work.

    @mailpoet please update the plugin even with the small fix.

    Greetings
    derRALF

    I disabled LayerSlider WP and deleted my message

    The WP Mail Logging plugin is not installed on my WP but I get the same error —

    Deprecated: contextual_help is deprecated since version 3.3.0! Use get_current_screen()->add_help_tab(), get_current_screen()->remove_help_tab() instead. in /xxxx/wp-includes/functions.php on line 5088

    Apparently another plugin causes this but I can’t find out which one…

    The reason is found — StagTools plugin

    Daniel

    (@danieldiaz)

    SOLUTION – In my wordpress the problem is the plugin “LayerSlider WP 6.10.2”.

    Used the Find feature in the plugin editor to locate each instance of the tag “contextual_help” and replaced them in the file with “wpmail_logging_contextual_help”

    This resolved the issue and error is no longer showing up.

    domaxi198

    (@domaxi198)

    Yes, I can confirm that the plugin “Page-scroll-to-id” caused the problem. After I deactivated it, the problem vanished.

    This message also appeared in a project and I identified that it was in other plugin, in the Monkeyman Rewrite Analyzer plugin (https://wordpress.org/plugins/monkeyman-rewrite-analyzer/).

    Change:

    add_action('contextual_help' ...

    To:

    add_action('current_screen', ...

    Remove all arguments, as for 3.3 it is not “filtered in” by adding anymore. It works as same as like adminbar->add by calling the current screen object:

    
    $screen = get_current_screen();
    $help_content = '<p>Hallo world</p>';
    $screen->add_help_tab(array(
    	'id'  => 'my-contextual-screen-id',
    	'title' => 'Screen information',
    	'content' => $help_content,
    ));
    jimmiebartlett

    (@jimmiebartlett)

    In my wp website the problem is plugin A2 Fixed W3 Total Cache. Deactivate it and the problem goes away. Reactivate and it comes back and shows on the top of my site page. Why am I seeing this if my debug is not enabled. My php debug is set to false so it should not be seen. Thanks!

    Garrett Hyder

    (@garrett-eclipse)

    FYI this should be fixed now, from the changelog;
    > 1.9.6 – 2020-05-05
    > Removed: contextual help tab.

    grep for ‘contextual_help’ in plugins or themes folder.
    Find the suspect theme/plugin and upgrade them.
    In my case it was outdated Layerslider plugin using ‘contextual_help’ which is deprectaed now.

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘contextual_help is deprecated since version 3.3.0’ is closed to new replies.