Support » Plugin: Posts By Tag » content="true" causes blank page to load

  • Resolved carriegisaac


    I’m experiencing some issues with the Posts By Tag plugin when using content=”true”. It’s been working great for months, then suddenly – I think it was either with the last plugin update, or the WordPress 3.5 update, it suddenly started making the page load completely blank.

    You can see it here:

    Here is a sample of what’s on that page:

    [posts-by-tag tags=”milk prices” number=”15″ thumbnail=”false” order_by =”date” content=”true”]

    When I remove content=”true”, the page loads fine. It started happening when I updated the plugin in the last week or two; unfortunately, I’m not sure if it’s a plugin or WordPress issue since I updated both around the same time. I’m using the same plugin on a different site with the same issue.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Sudar Muthu


    That’s quite strange.

    Can you find out if there are any errors in the PHP error log file?

    Here are a couple of mentions of the plugin in the error_log:

    [12-Jan-2013 23:23:11] PHP Fatal error: Out of memory (allocated 33292288) (tried to allocate 30720 bytes) in /home/jeremy24/public_html/ on line 428

    [06-Jan-2013 04:15:34] PHP Fatal error: Out of memory (allocated 32768000) (tried to allocate 7680 bytes) in /home/jeremy24/public_html/ on line 177

    There are a few other mentions but not a ton.

    I just reverted to the 2.7.1 version and it works again!

    Denver Milk Price Tracker

    Plugin Author Sudar Muthu


    The error message basically says that your PHP process is running out of memory.

    When you revert back to 2.7.1 version of the Plugin, did you also revert back to the same config including tags?

    Yes, all I did was deactivate and delete the 2.7.2 plugin, then upload and activate the 2.7.1 plugin.

    Plugin Author Sudar Muthu


    There was only one small change between 2.7.1 and 2.7.2. Not sure how it is affecting this. Had a brief look at the code but couldn’t figure out anything.

    Are you also using the same tags both in 2.7.1 and 2.7.2?

    I’m having a similar issue, though in my case I get an Internal Server Error message. I reverted to 2.7.1 and it works just fine. I am using the same tags in both instances:

    [posts-by-tag tags = “instructional videos” number = “50” excerpt = “false” thumbnail = “false” order_by = “date” order = “desc” author = “false” date = “false” content = “true” tag_links = “true”]

    This site has several pages using this plugin and all worked with 2.7.1 (but not with 2.7.2). Please let me know if I can provide any more information that might help.

    (P.S. Thanks for creating this plugin, it’s very useful! Good luck with figuring this one out!)

    Plugin Author Sudar Muthu


    Hmm, so there is definitely a bug out there hiding somewhere 🙁


    Can you look into your PHP error_log and let me know if you find anything there? If you are getting the same error like OP, then let me know how much memory is allocated to PHP?


    Can you let me know what is the memory limit set in php.ini file?

    I didn’t change the markup of the tags or page at all – just reverted to an old version of the plugin as described.

    Hope you are able to get it figured out soon (assuming it’s not just an isolated issue)! Thanks for the great work on the plugin.

    Mine is set to 256M on one site and 128 on the other (both were experiencing the same issue).

    I only just enabled the error logs (it’s an inexpensive, shared hosting website) but the default memory limit is 64M. If it helps, I could reinstall 2.7.2, access the affected pages, and then see if the error logs have anything?

    Plugin Author Sudar Muthu



    That would be really helpful for me to debug this issue.

    I am still trying to replicate this issue in my dev setup, but couldn’t.

    Plugin Author Sudar Muthu


    @soundsmith and @carriegisaac

    I finally managed to find the bug. It was a very corner case, that resulted in an infinite loop.

    I have fixed it and released v2.7.3 of the Plugin. Kindly test the latest version and let me know if you continue to face this issue.

    Once again, thanks for reporting this issue. I wouldn’t have figured it out otherwise.

    Plugin Author Sudar Muthu


    Marking it as resolved, since the issue is fixed. Reopen if you still face the issue.

    Thank you so much – the update works great!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘content="true" causes blank page to load’ is closed to new replies.