Support » Plugin: Events Manager » CONTENTS not being replaced with SiteOrigin Page Builder

  • Resolved funkatr0n

    (@funkatr0n)


    When using SiteOrigin’s Page Builder to create a layout with rows and columns, assigning a block with the plain text CONTENTS (for the events page), does not get replaced by Event Manager. Rather, it just displays the text “CONTENTS.” When NOT using PageMaker for layout (such as a static page or Visual Editor), CONTENTS is properly replaced. Is there any way to use the PageMaker layout tool and have Events Manager properly replace CONTENTS in the page? Here is the code generated around the area:

    `<div class=”entry-content”>
    ‘<div id=”pl-78″>
    ‘<div class=”panel-grid” id=”pg-78-0″ >
    ‘<div class=”panel-grid-cell” id=”pgc-78-0-0″ >
    ‘<div class=”so-panel widget widget_text panel-first-child panel-last-child” id=”panel-78-0-0-0″ data-index=”0″>
    ‘<div class=”textwidget”>CONTENTS</div>
    ‘</div></div>

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    Because the placeholder is working correctly when used in the normal way, I think you’d need to ask Page Builder support if there’s something they can suggest.

    I have the same problem. When I contacted Page Builder developers (SiteOrigin) they acknowledged there is a clash between SiteOrigin Page Builder 2.6.x and Events Manager but said there weren’t enough people using both Page Builder & Events Manager to warrant giving it high priority. They suggested I reverted to Page Builder 2.5.x which I did and it works OK.

    Siteorigin developers have just sent me the following way around the problem – which works.

    “This is being caused by the Events Manager plugin changing and overwriting panels_data post meta. It worked previously because their code was running before ours, but now when copy content is enabled we trigger another save_post which then causes their code to run again and overwrite our saved post meta with incorrectly serialized data. I think this should be up to them to fix and it may be as simple as them just making sure they don’t run save_post filters more than once.

    You should be able to work around this issue by disabling copy content. Copy content can be disabled by navigating to WP Admin > Settings > Page Builder and opening the Content tab. Untick Copy Content. This will prevent Yoast from analyzing text but outside of that, you will not experience any noticeable differences. If Yoast is very important to your website (specifically the text analysis functionality), I would recommend keeping Copy Content enabled and then disable it when editing Events.”

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘CONTENTS not being replaced with SiteOrigin Page Builder’ is closed to new replies.