WordPress.org

Support

Support » Plugins and Hacks » Content Warning » Content Warning V2 Redirecting to Google After Clicking Enter

Content Warning V2 Redirecting to Google After Clicking Enter

  • I’ve recently had a reader tell me that my content warning was redirecting her to Google after clicking to enter my site. I’ve also had this issue, and tested it both on Chrome and Firefox. As a temporary solution, I have it redirecting to my main url, but this is definitely not the solution I had in mind. I need it to let the user go to whatever url on my site that they were intending to go to, but redirecting them to my main url is all I can do to fix the redirecting-to-google problem right now.

    I’m not sure how long this has been going on, but I need to get this fixed ASAP.

    Updated to latest version of WordPress.

    My Current Settings:

    Sitwide Option: Enable site-wide acces from one dialog.
    Kill Immediately: checked
    Allow Per-Page/Post Overrides: No
    Default for Overrides: Dialog Enabled

    Exit: http://www.google.com
    Enter: http://www.truepleasuresreviews.com

    Toggle Denial Options: Disable (Us the dialog options for denial.)

    http://wordpress.org/extend/plugins/content-warning-v2/

Viewing 10 replies - 1 through 10 (of 10 total)
  • The same thing has been happening to the plugin on my site as well. Exactly the same settings as TruePleasures, but no matter Enter or Exit, it goes to Google.com which I set as my exit site.

    http://staplerman.com/kinky

    The same to me. So I’m still using version 2.4.15.

    I also am having the same issue. I tried to contact the author of this plugin on his site. The support form is disabled and states that it failed to send and I should try and contact the admin a different way.

    Very sad for such a useful plugin.

    at content-warning-v2/main.php, line 77, it shows like this.

    ‘enter_url’ => (empty($enter_url) ? ‘http://www.google.com’ : $enter_url),

    this will set the enter url to google if setting is empty so I changed it like this.

    ‘enter_url’ => $enter_url,

    then it works fine.

    Worked like a charm, thanks juangotoh!

    Sure did, Thanks juangotoh!

    I changed the bit of code in the main.php and it is still doing the same thing for me. I delete cookies, reload the page and hit enter and it still goes to Google.

    Plugin Author Jerry

    @phyrax

    Guys I’m profusely sorry for my absence, I’ve had a ton of clients to deal with lately, some more important than others.

    @juangotoh:
    You’re correct, setting that to the enter_url variable will work, it just set’s the link to a “blank” link if the option is empty from the admin page. I’m fixing that now, it’s a small bug.

    Here’s what’s in the update coming:

    // Line 77, /content-warning-v2/main.php
    'enter_url' => (empty($enter_url) ? 'http://www.google.com' : $enter_url),

    I don’t know why I set it to a default but I’ll fix it.

    $scriptParams = array(
    ‘postID’ => $postID,
    ‘url’ => get_bloginfo(‘url’).”/wp-admin/admin-ajax.php”,
    ‘exit_url’ => get_option(‘wpcwv2_msg_exit_url’),
    ‘enter_url’ => $enter_url,
    ‘cwv2DataNonce’ => wp_create_nonce(‘wpcwv2_ajax_data_nonce’)

    Did I do it right this way? Or is it the one below?

    $scriptParams = array(
    ‘postID’ => $postID,
    ‘url’ => get_bloginfo(‘url’).”/wp-admin/admin-ajax.php”,
    ‘exit_url’ => get_option(‘wpcwv2_msg_exit_url’),
    ‘enter_url’ => (empty($enter_url) ? ‘http://www.google.com’ : $enter_url),
    ‘cwv2DataNonce’ => wp_create_nonce(‘wpcwv2_ajax_data_nonce’)

    I can’t seem to get it working no matter which code I tried. I guess I’ll just wait for an update.

    Plugin Author Jerry

    @phyrax

    Just submitted the patch now should be fine. FYI my support form is working now so if this doesn’t work just shoot me some admin creds and I’ll see what I can fix.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Content Warning V2 Redirecting to Google After Clicking Enter’ is closed to new replies.
Skip to toolbar