Support » Plugin: Content Views - Post Grid & List for WordPress » Content view not working after changing theme

  • Sitebuilder

    (@valetrends)


    Hi

    So after I changed theme it seems the Content view plugin is not working anymore.

    I did this on one of my categories before. So that when you went into those categories you would see a gallery view. I still have that code string pasted in the category’s field. But it is now a list view for that category again. Even though I have set it to “gallery grid”. Why is that?

    How can I make it work again?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Content Views

    (@pt-guy)

    Hi there,
    Did you paste the View shortcode to the description field of each category?
    If so, your old theme shows and executes shortcode in description field,
    but your new theme doesn’t do that.

    So you need to modify the new theme (to read and execute shortcode in description field of category).

    Or, there are 2 other solutions:
    – switch back to old theme
    – or upgrade to our Pro version. It has the “Replace Layout” feature, which helps you to use our grid on Category page with your new theme. You don’t need to modify the new theme anymore. Even you change another theme in future, our grid still remains on Category page.

    Best regards,

    Sitebuilder

    (@valetrends)

    “Hi there,
    Did you paste the View shortcode to the description field of each category?
    If so, your old theme shows and executes shortcode in description field,
    but your new theme doesn’t do that.”

    Yes I kept the old code. The green one. But I have also tried to deactivate the plugin and install it again. But it still does not work for some reason.

    “So you need to modify the new theme (to read and execute shortcode in description field of category).”

    How can I do that?

    Sould I paste the “For theme file” code somewhere? And if so, where?

    Plugin Author Content Views

    (@pt-guy)

    Hi there,
    1. Yes I kept the old code. The green one. But I have also tried to deactivate the plugin and install it again. But it still does not work for some reason.
    => As I replied to you before, that is new theme’s problem.
    You must to modify the new theme. There is nothing to do with our plugin.

    2. How to modify new theme?
    => Sorry we have no experience with that theme to help you.

    Let me summary, this issue caused by the new theme (it doesn’t execute and show the shortcode in description of category)
    .
    If you don’t know how to modify it, just switch back to the old theme. Then all things work again.

    Best regards,

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.