[resolved] Content vanishes due to wp_posts table being "in use" (3 posts)

  1. groomedmonkey
    Posted 6 years ago #

    One of my wordpress sites just lost all of its content: posts, comments, and pages but the site itself is still functional. I looked into it and discovered that the wp_posts table in the database shows a weird "in use" declaration. See screenshot:


    Looking into that I believe that something is locking the table. Has anyone experienced this and know more about what could cause it? A plugin perhaps? A bit disturbing to 'loose' all of ones data.

    Meantime I and hoping that my host can restart mySQL and that will solve it...

  2. groomedmonkey
    Posted 6 years ago #

    Haven't worked out what could cause this to happen but to fix it you need to check/repair the database.

  3. vernon108
    Posted 5 years ago #

    Thanks for the solution! I had a similar problem, caused by making changes to the W3 Total Cache plugin (I believe turning on database caching was what did it--possibly because of an unforeseen interaction with another plugin). All of the comments on my site had disappeared, and I was freaking out, but running the table repair in phpMyAdmin fixed it.

Topic Closed

This topic has been closed to new replies.

About this Topic