Support » Plugin: Seriously Simple Podcasting » Content Template being ignored

  • stephendew

    (@stephendew)


    Hi,

    I have a problem with SSP and my theme.

    I am trying to set a content template for Podcast Series. However the /podcast page will only ever display the template set for all Archive pages.

    I have tried checking that there are no conflicting WordPress categories of the same name. Tried updating permalinks. And I have tried everything I can to swap out and test it, however, I can’t find the solution to my issue.

    This sounds like a similar issue raised in this forum post: https://wordpress.org/support/topic/custom-archive-template-being-ignored-solution/ However I have already disabled all Podcast post types.

    Please help,

    Thanks,
    Steve

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi @stephendew

    Thanks for the message and the details here. In looking at your site it seems that your /podcast page is showing the same kind of layout as other archive pages (such as https://www.freshradiouk.co.uk/category/blog/entertainment/). Have you created a new custom page template yet that you want to use on the Series page? If not then https://support.castos.com/hc/en-us/articles/360018867300-Create-custom-podcast-templates walks through that.

    If so and it’s a matter of the page not rendering the proper template please let us know so we can dig into things further. We’ve used https://wordpress.org/plugins/which-template-file/ in the past to help determine which theme files are being used on which pages during troubleshooting like this. Might be helpful.

    Thread Starter stephendew

    (@stephendew)

    Hi Craig,

    Thanks for getting back to me, I’m still stuck with this.

    I have created an archive-podcast.php file and I have installed the Which Template File plugin and for the archives page it’s showing archives.php and for the podcast archives, it is showing archive-podcast.php – so it seems to be set up ok.

    The design of the podcast series page has been done in the “Page Templates” section of the theme – do you think this could be a theme issue and maybe something in archive-podcast.php needs changing?

    Thanks for your help in advance,
    Steve

    Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi @stephendew thanks for the updates here. Yes, in order for the contents of the /podcast (or Series) pages you’ll need to modify the contents of the archive-podcast.php page to reflect the content/style changes you’re looking for. I don’t believe most themes will give you the ability to modify those page templates from the wp-admin dashboard. It’ll be actual code level changes in your theme that you’ll need to do.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.