Support » Plugin: Jetpack by WordPress.com » content shared to fb have no thumbnails

  • Resolved stevecorwin

    (@stevecorwin)


    When I share content from my site to fb using the social media sharing button supplied by jetpack, there is no thumbnail. When I debug the url with fb debugging tool, I get the “facebook urls cannot be crawled” error.

    don’t know what to do about this

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 20 total)
  • Have you set the “featured image” in the post editor?

    …I just tried sharing your home page and the thumbnail appeared as normal

    I have tried setting featured image

    I tried the home page and thumbnail appeared for me also. I’m having trouble with individual posts, but not all of them. The ones that won’t show thumbnail, refuse to do so no matter what image I use in the post, even the same image that shows up for its corresponding post when I share it.

    Got me really frustrated

    The post i’m having trouble with is https://bridgetales.com/the-beginning-of-the-tale/#more-363

    I’ve tried social media plugins, yoast seo. Nothing fixes problem. Now, some of my posts, when shared, are showing images from other posts that don’t even exist on my server anymore. This can’t possible be this convoluted. Isn’t sharing to social media one of the top points of having a blog site in the first place?

    I don’t what to do at this point. I’m about to shut the site down, cancel my bluehost account, and start over with another host.

    • This reply was modified 1 year, 8 months ago by  stevecorwin.
    Plugin Contributor Cena

    (@cena)

    Hi Steve,

    Don’t give up just yet! 🙂

    When I run some diagnostics test on your Jetpack connection, I can see that it’s not properly connected to WordPress.com.

    As a first step, would you try simply disconnecting and reconnecting Jetpack? To disconnect and then reconnect Jetpack, first go to Jetpack in your site’s wp-admin dashboard. Then, scroll down to the Connections area. Click the “Manage site connection” link as shown here:

    ![](http://d.pr/i/RR3e+)

    Then, click the red “Disconnect” button as shown here:

    ![](http://d.pr/i/IUxi+)

    Click that, then reconnect to WordPress.com when you see the prompt to do so.

    Check this page: https://jetpack.com/support/debug/?url=https://bridgetales.com/

    Does it say “Everything looks great!”? If not, let us know and we’ll go from there.

    Best,
    Cena

    you probably ran the test while I was switching plugins (I had temporarily disabled jetpack)

    I did what you said and I see “everything looks great”

    No change whatsoever to the problem of thumbnails showing up properly

    Looking at the facebook debugger, when I try to rescrape that page, it gives this error message:
    Provided og:image, https://bridgetales.com/wp-content/uploads/2018/01/writing-in-jail.jpg could not be downloaded because it exceeded the maximum allowed sized of 8Mb or your server was too slow to respond.

    Just checked the image and the file size is only 26.5kb so it’s not a size issue

    I see you have the yoast seo plugin active. Both yoast and jetpack will be trying to generate the og:image (facebook thumbnail) properties so you should disable one of them.

    Try going to https://bridgetales.com.com/wp-admin/admin.php?page=wpseo_social#top#facebook and disabling Open Graph meta data.

    Now, suddenly, the problem post I linked to in previous comment is supplying the proper thumbnail to fb.

    Still having problem with certain posts showing up with thumbnail from other posts. See the “Stories coming soon” and “Forgiveness Reading list” posts under Blog section of my site. When I share them, the pic from the “April Kauffman’s daughter Pack ‘working on forgiveness” post shows up. What shows up for you?

    I’ve spent hours disabling one or the other, installing different plugins, all to no avail. I’ll disable open graph meta data via Yoast

    The post “Inspiring words from Les Brown” is pulling up the wrong thumbnail though. Does that post have a featured image?

    no change

    The Les Brown image is too small so the default image is selected. I’m aware of that one and not really worried about it. Just wondering why the other two are pulling an image from a completely seperate post.

    Stories coming soon does’t have a picture in the post so that could be why it’s pulling up other random pictures. The same is true for forgiveness reading list.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘content shared to fb have no thumbnails’ is closed to new replies.