Support » Plugin: Jetpack by WordPress.com » Content Options Remove All Featured Images, not just primary

  • Resolved mrwweb

    (@mrwweb)


    I’m making a child theme of Ixion and am setting up a custom Grid Page template that will show features images of child pages of the page with the template.

    However, in my template, I can featured images don’t appear. When I enable Featured Images for single Pages, they appear. I’ve gone through the Jetpack files and don’t see a way to override/filter whatever the hiding of the images.

    I’ve found a workaround for now, but it’s frustrating that it’s a fairly broad removal of featured images beyond the one specifically for the page.

    Even when I tried a work-around, get the ID of the feature image from meta and placing the attachment image, it still didn’t appear.

Viewing 1 replies (of 1 total)
  • Plugin Support KokkieH

    (@kokkieh)

    Hi there,

    This is how Content Options is designed to work – if you disable featured images for single pages they won’t show for the page itself, nor will they show for any posts or pages embedded on the page, e.g. via a grid page template or a shortcode.

    If you don’t want featured images to show for your pages themselves, I’d recommend rather adding CSS to your child theme’s style sheet to hide the featured image on pages, while leaving that option enabled in Content Options so the thumbnails for pages in the grid will appear.

    You can use something like this:

    /* Hide featured images on single page */
    .page .post-thumbnail {
    	display: none;
    }

    Or if you only want your grid page to behave this way, you can even use the page-id class to target that specific page only.

Viewing 1 replies (of 1 total)
  • The topic ‘Content Options Remove All Featured Images, not just primary’ is closed to new replies.