Support » Fixing WordPress » Content not showing on single post page

  • Resolved cyberroth


    I’ve just installed my blog at, and most of it is working just as it should. The exception is the single-post page, which shows the entry title and date but not its content, not the comment form, and not the sidebar.

    Each of these items is called for in single.php but doesn’t show up. I’ve tried pasting the code from index.php over the code from single.php, but the problem persists. I’ve tried installing several different themes, but the problem persists. I’m not a php programmer, so I have reached the end of what I can think to do. Any suggestions? Is it possible I have to do something special with the code since WordPress (and my blog) are not installed in the root directory?

    Thanks for your help.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi

    Looking at View Source of your single page, your code simply ends before the display of the content – no content, no footer, no closing page tags.

    If you can’t find the problem, post your single.php code in a pastebin and post the link to the code here

    Thank you for looking into this, stvwlf. You can find the code here:


    For comparison’s sake, here is the code for my (working) index.php:

    Thanks again.

    Hi Julie

    I’m not sure what is going on. I replaced the single.php from the default theme in a WP install with your single.php and the page displayed fine.

    That tells me the problem is probably not with single.php

    Your page just stops outputting just before reaching the_content. Nothing after that displays.

    Look in your WordPress install folder and see if there is an errorlog file. If so, open it in an text editor (such as Notepad if you don’t have any other), scroll to the bottom, and see if there are recent log entries, noting what they are.

    Thanks stvwlf. After all the checking and double-checking, I’m glad to have you confirm it’s not the single.php file (although that would have been easier).

    I’m unable to find an errorlog file, which either means no errors have been logged or that I’m not looking in the right place (which is unlikely since I’ve gone through all the folders installed with wordpress).

    Maybe it’s higher up in the food chain. Is there something different about how the single.php template is called vs. how index.php or archives.php are called?


    Hi Julie

    No, there’s no inherent difference between how single.php and index.php etc are applied. A thought… temporarily switch to the default WordPress theme and see if the display of single pages now works correctly. If it does, that points to the problem being within your theme. If it doesn’t, to a problem with the WP install or server config.

    Also, see if there’s an error log in the root folder of your site, above the blog installation.

    Hm. Unfortunately I deleted the default theme. But I’ve tried the site with 6 other themes, and had the same problem. No error logs, either.

    Should I try reinstalling WP?

    Yes, that is a starting place.

    Check with your webhost and see how much memory the PHP process is allowed. Tell them you want it set to 32 megs if its less than that and how do you do that?

    Also, don’t delete the default theme as WordPress falls back on it when certain things go wrong with the installed theme.

    Hi stvwlf. We have a good news/bad news situation now. I reinstalled WordPress and my karappo-style theme, and the single-post pages work (hooray!). But then I imported my backup db to the new site, and I began getting new errors. Now when I try to go to the dashboard or to the public page, I get the message below:

    Warning: main(/homepages/24/d171933638/htdocs/blog/wp-content/plugins/wp-super-cache/) [function.main]: failed to open stream: Success in /homepages/24/d171933638/htdocs/blog/wp-settings.php on line 473

    Warning: main() [function.include]: Failed opening ‘/homepages/24/d171933638/htdocs/blog/wp-content/plugins/wp-super-cache/’ for inclusion (include_path=’.:/usr/lib/php’) in /homepages/24/d171933638/htdocs/blog/wp-settings.php on line 473

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/24/d171933638/htdocs/blog/wp-settings.php:473) in /homepages/24/d171933638/htdocs/blog/wp-includes/pluggable.php on line 850

    I’ve uploaded my wp-settings.php file here in case you have time to take a look:

    Any thoughts?


    Hi Julie

    Technically what is going on is Supercache is being seen in your “active Plugins” list in the database data you restored. wp-settings is thus trying to load it, and its not finding the plugin files.

    If you can log into the admin area, go to the plugins page, disable Super Cache, and see if that gets rid of these errors.

    Based on those errors, its possible that SuperCache won’t be listed there at all. In that case you might upload the SuperCache plugin into the plugins folder and activate it, to bypass the error warnings.

    As FYI, unless you have a pretty high amount of site traffic (as in, getting hit from Digg listings) its not necessary to use the super-cache plugin. If you don’t need it you can deactivate it once the errors have cleared.

    Well, it took me awhile to figure out how to edit my database to fix this newest problem, but I’ve done it. And now all problems are fixed. Thank you so much for your help, stvwlf. Bottom line: fixing the original problem required reinstalling WordPress.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Content not showing on single post page’ is closed to new replies.