Support » Plugin: Price Based on Country for WooCommerce » Content not loading in some locations

  • Resolved greengriff


    We’re using the plugin to show different product prices to Spain based and UK based visitors to our site. We noticed during testing that the site content that would be affected by the plugin (e.g. the goods we are selling) doesn’t load in the UK. If I use a VPN to simulate being based in a random foreign location then the content loads fine. The site header and menu load in all locations

    We noticed this today. We also noticed that there was an update to the plugin this morning. Could that have anything to do with it?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Oscar Gare


    what content do you mean? PBoC only modifies the product prices.
    Did you update to 1.8?
    Did you a test with PBoC disable?
    Are you using a plugin to restrict o block content?
    Could you check your PHP error log? Maybe some something is triggering an error.

    Also, I checked you are using the WooCommerce option “Gecolocate with page caching support”. Could you change the option to Geolocate (only) and enable the “Caching support” option at WooCommerce > Zone Pricing > General option. After, clear the cache of your cache plugin (or your hosting)

    Hi Oscar,

    The content that’s not loading are our products.
    Yes we did the update.
    With PBoC disabled the site loads perfectly.
    We are not using any plugin to block content.
    I’ll get my colleague to check the PHP error log.


    Plugin Author Oscar Gare


    We received one ticket with a similar issue. Were you using the Pro add-on (or some of the old add-ons for PBoC)

    Plugin Author Oscar Gare



    We released version 1.8.3 of PBoC Basic. Version 1.8.3 should fix the issue. You have to update to version 1.8.3 and after updated, run the database update.

    Thanks for the feedback.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.