Support » Theme: Venice Lite » Content Jumping with JavaScript Enabled

  • Resolved dromanov31

    (@dromanov31)


    Hello!

    When loading any page of my blog, page elements (fonts, divs and menu bar) jumps slightly. It happens in any browser, even on mobile device.

    When I disable JavaScript, pages load correctly (excluding elements which need JS).

    I suppose this bug happens because of niceScroll.js but I can be wrong with this.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter dromanov31

    (@dromanov31)

    Solved after 4 hours of trying and searching.

    The problem was in inline CSS (I don’t know exactly from where it loads). It is setting height of menu bar to 54 px. But in template.css the height was 46 px. That’s it!

    I’ve set the height value in template.css to 54 px, and now everything works just fine.

    Theme Author alexvtn

    (@alexvtn)

    Hi @dromanov31,
    thanks for sharing this fix with us.

    I’ll check this issue as soon as possible

    Have a nice day

    Alex

    Thread Starter dromanov31

    (@dromanov31)

    I’ve just installed clean WordPress with clean Venice Lite theme.

    Content jumping depends on the font size of the menu. The bigger the font the more noticeable jump.

    For example, when menu font size is set to 22 px, inline style height of header-wrapper div is 59 px, but in template.css this height is always 46 px.

    I also noticed that header-wrapper height inline style loads dynamically. But there are lots of JS scripts in this theme, so I can’t understand which of them inserts this inline style 🙂

    Theme Author alexvtn

    (@alexvtn)

    Hi @dromanov31,

    This is not a bug of Venice theme.

    A javascript function automatically adjust the topbar heigh, based on the menu font size.

    You can include the following custom css code, as you said, going to appareance > customize > additional css

    #header-wrapper { height:54px}

    Have a nice day

    Alex

    Thread Starter dromanov31

    (@dromanov31)

    Ok, thanks 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Content Jumping with JavaScript Enabled’ is closed to new replies.