Support » Plugin: RPS Include Content » Content is reformatted

  • Resolved taastrategies

    (@taastrategies)


    Thank you for the plugin. It was working nicely until I did some editing on the source page.

    I use this plugin to replicate page A in page B. Page A is used for normal website viewing while Page B is used for linking from newsletters without displaying menus and other items. Page A is divided into reference sections which are used in the newsletter to display specific sections.

    The problems can be seen by viewing the two pages:

    Page A: https://taastrategies.com/performance/
    Page B: https://taastrategies.com/performancereference/

    Note that the beginning 3 paragraphs are all run together and further down, whole sections are merged together.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author redpixelstudios

    (@redpixelstudios)

    Looks like the content filter may need to be run on the included post. Try adding the filter=”true” argument to your shortcode and see if that resolves the issue.

    Thank you for the suggestion.

    [rps-include post=414 filter=”true”]

    Resulted in no change.

    Plugin Author redpixelstudios

    (@redpixelstudios)

    Would it be possible for you elaborate on the changes you made to the source page? Was there some content added which relies on another plugin to generate it, such as the tables in the example? If so, it could be that another plugin is stripping the paragraph tags, though it’s not so easy to diagnose beyond disabling plugins one at a time to find the culprit.

    The changes involved adding some copy with images and rearranging copy.

    The page content is vanilla WP text and images with exception of the buttons which use the Forget About Shortcode Buttons plugin in the lower part of the page to build the button image. There is no content which is generated by plugin or externally.

    The only copy which may be unusual is the use of “<div id=” to section the copy for section referencing. This begins at “Global Core + Global Satellite (50%)”

    There is nothing special in the first three paragraphs which are being run together.

    The lower Performance Table Explanations which is being run together is indented and uses Control+Shift at the end of each line to avoid the between line spacing associated with creating new paragraphs.

    Plugin Author redpixelstudios

    (@redpixelstudios)

    Understood. Could you revert your page source changes to see if the problem goes away? If so, then we would know it was something specific to the content of the page and not a symptom of a broader problem. In any case, we will need to get to the point where we can replicate the issue so it can be resolved.

    Sorry, but I can not revert the content w/o restoring the entire website from backup which affects numerous other pages. I limit the revision stack to 5. Fortunately, an older version exists in a sandbox at:

    http://taas.alishawordpress.com/aeducation/performance/
    http://taas.alishawordpress.com/aeducation/performancereference/

    I was mistaken in thinking that the problem started with the recent edit. The 3 front paragraphs were run together as were the reference list at the bottom.

    I see no other course for debugging than to replicate my page source

    Page A: https://taastrategies.com/performance/
    Page B: https://taastrategies.com/performancereference/

    and look for whatever conditions are triggering the issue.

    Plugin Author redpixelstudios

    (@redpixelstudios)

    No problem. It sounds like at some point the content was formatted properly. Were there any other aspects of the site that changed (WordPress, theme or other plugin updates) which might correspond with the emergence of the issue?

    Plugin Author redpixelstudios

    (@redpixelstudios)

    Just to help out a bit more, we went ahead and created a clean install of WordPress, added the GeneratePress theme and made sure that only the RPS Include Content plugin was active. Then we created two pages, one to be used as the source and the other to be the destination (wrapper) for the content. The default shortcode [rps-include post=”5″] resulted in the missing paragraph tags. However once we updated the shortcode to [rps-include post=”5″ filter=”true”], the paragraph tags were included in the destination. So it sounds like there is another factor influencing the output.

    Tested with:
    WordPress 4.7
    GeneratePress 1.3.41
    RPS Include Content 1.1.6

    Not to my knowledge, but why are we chasing history of an indeterminate nature and time?

    I have tested turning off the cache and duplicating the Elements on Page A to Page B. Nothing makes a difference.

    The body of Page A is pure WordPress text and png’s. The code on Page B requests that the same info and format be reproduced on Page B. Page B lacks the sidebar and menu.

    The replication is faulty. In checking Page B more closely, I see that all “paragraph” level paragraphs (not just the text at the top) are merged into one paragraph even when paragraph is terminated with Enter. Nor is the plugin coping with lines terminated with Shift+Enter.

    Plugin Author redpixelstudios

    (@redpixelstudios)

    Because it is often helpful to track down when a problem occurred so that factors can be identified as possible causes. Though in this case it would seem the information regarding when the problem actually occurred and what changed at that point in time is not available.

    In our testing, the output is as expected with the latest version of WordPress, GeneratePress and RPS Include Content. So at this point, it must be another factor within your WordPress environment that is causing the issue.

    You may need to disable all plugins except RPS Include Content and see if the problem resolves. If not, there may be something specific to your version of the GeneratePress theme we would need to look into. If so, then you could just activate plugins one at a time until the problem appeared once again.

    Problem solved. I copied your [rps-include post=”5″ filter=”true”] into my page and changed the post number: [rps-include post=”414″ filter=”true”]. It worked. I then rolled back the version to the same short code as I posted in the 3rd post in this thread: [rps-include post=414 filter=”true”]. The highlighter showed the absence of quotes around 414.

    I have toggled it back and forth several times and the behavior is repetitive. Paragraphs run together w/o quotes around the page ref and display properly with quotes around the page ref.

    Thank you for your help.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Content is reformatted’ is closed to new replies.