Support » Plugin: LifterLMS » Content for logged in user are showing to not logged in users

  • Resolved 0rbita

    (@0rbita)


    Hello,

    Every course I created I changed the enrollment visibility so the curriculum could be seen only by enrolled users in that course.
    However, as you can see by opening the page above, even not logged in users can see the curriculum of the course. I put one page as an example, but it happens to every course I had.
    And here: https://uploaddeimagens.com.br/imagens/enrolled_users_content-jpg you can confirm the setting I’ve just told you about.

    Thank you

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Natalie

    (@nrherron)

    Hi @0rbita,

    Yes, I can see the issue you are talking about!

    If you click on the three vertical dots in the upper right hand corner and change the view of the course editor from Visual to Code, can you send us a screenshot of the code in the course editor so we can look for what is preventing the visibility from functioning properly?

    Let us know if you have any questions about finding this setting!

    Thanks and take care,

    0rbita

    (@0rbita)

    Hello @nrherron ,

    Thanks, hope that’s what you need:

    <!– wp:heading {“level”:4} –>
    <h4>Oi, quilter! Você já fez o seu login e chegou a hora tu-do de quilting para patchwork!</h4>
    <!– /wp:heading –>

    <!– wp:paragraph –>
    <p>É ultra simples navegar nas aulas deste curso:</p>
    <!– /wp:paragraph –>

    <!– wp:list {“ordered”:true} –>

    1. Acesse o “Conteúdo deste curso”<br>– acesso facilitado na barra lateral em notebooks ou então continue descendo sua tela e veja a lista de aulas abaixo da apresentação das professoras
    2. Clique na aula que deseja assistir<br>– recomendamos seguir a ordem das aulas conforme a listagem das aulas
    3. Após assistir a aula, clique em “Marcar como completo” para poder atualizar o seu progresso no curso<br>– assim, quando você voltar a assistir este mesmo curso, saberá exatamente onde parou
    4. Caminhe pelas aulas do curso pelos botões “Aula Anterior” ou “Próxima Aula”<br>– localizado logo abaixo do conteúdo de cada aula

    <!– /wp:list –>

    <!– wp:llms/course-information {“title”:”Informações do Curso”} /–>

    <!– wp:llms/instructors {“llms_visibility”:”not_enrolled”,”llms_visibility_in”:”this”} /–>

    <!– wp:llms/course-progress –>
    <div class=”wp-block-llms-course-progress”>[lifterlms_course_progress]</div>
    <!– /wp:llms/course-progress –>

    <!– wp:llms/course-continue-button –>
    <div class=”wp-block-llms-course-continue-button” style=”text-align:center”>[lifterlms_course_continue_button]</div>
    <!– /wp:llms/course-continue-button –>

    <!– wp:llms/course-syllabus {“llms_visibility”:”enrolled”,”llms_visibility_in”:”this”} /–>

    The screenshot would not capture the entire page, that’s why I copied it.

    Plugin Support Natalie

    (@nrherron)

    Hi @0rbita,

    Thank you for the code!

    The code looks correct and should be working, however can you try adding this shortcode in place of the syllabus that is currently there to see if this will hide it for logged out users:

    [lifterlms_hide_content][lifterlms_course_syllabus][/lifterlms_hide_content]

    Let us know if this works for you!

    Thanks and take care,

    Hello @nrherron ,

    Thanks, I tried to replace it a few different ways since I am not sure how it suppose to look like.
    But nothing has hidden the information.

    Thank you

    Plugin Support Natalie

    (@nrherron)

    Hi @0rbita,

    On your course page do you have the option to show custom sales content on that page?

    If so, if you turn off the option to show the sales content does it allow the main content on that page to be hidden?

    I am able to recreate the issue under those settings, so if you could let us know if this is what you are seeing as well, or how we can set up a test course page to look the same as the way you have your set up we can do some further testing to see about getting this resolved for you!

    Let us know if you have any questions about finding this information!

    Thanks and take care,

    Hello @nrherron

    Yes, I always used the custom sales content.
    So I changed it to show the standard content, but nothing has changed.
    Here’s the course I’ve changed it:

    https://www.unioqs.com.br/curso/master-quilter-o-estupendo-jogo-de-tabuleiro-para-criar-designs-inesqueciveis/

    Thank you

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @0rbita

    As I’ve noted in other of your threads we believe this is an issue related to your webhost, SiteGround. We’re currently working with SiteGround to see how we can work together to resolve these kinds of issues on their servers.

    Thanks,

    Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    @thomasplevy This is not a hosting related problem for sure. Our full page caching system (NGINX reverse proxy) completelly bypasses logged in users. Since when users login they get the wordpress_logged_in_ cookie, you will be able to see that we start returning the x-proxy-cache: BYPASS header which means that the visitor is receiving completely dynamic content.

    @0rbita I’ve noticed that you’ve enabled the Minify and Defer Render-Blocking Scripts optimizations in the SG Optimizer -> Frontend Optimizations tab. I’ve excluded the LifterCMS scripts from the former and stopped the minification altogether.

    Then, I registered for one of your free courses and everything seemed to be working just fine. Please, check on yhour end whether everything is working fine.

    Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @hristo-sg,

    Based on the information we’ve been able to gather from the @0rbita I cannot determine one way or another what is actually happening on this site but based on information we’ve gathered (and been able to reproduce on other tickets) cached content still seems to be served to logged in users regardless.

    I appreciate your help on this and we’ll be investigating this further on our own thanks to your help as we’ve been backchanneling.

    It’s really easy to point fingers and I’m glad you’ve been able to do a little debugging for us. I was hoping you’d be able to provide us with a clear path to resolving this issue but it seems like we have a lot more internal work to do to figure out why this works on most hosts but recently not on SiteGround so well.

    Thanks everyone involved for remaining patient.

    Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    All the cases I’ve been through have nothing in common. One has our Dynamic caching on, another user – not. One has CloudFlare enabled. Different PHP versions, etc. Maybe it’s just that we host a LOT of websites. I hope the account I opened will help you with the troubleshoot. As I said, if you point us to an exact issue – we will solve it but as of now I can’t find anything to blame 🙁

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.