WordPress.org

Forums

Content editor text not displaying (3 posts)

  1. wp-rory
    Member
    Posted 2 years ago #

    Hi all,

    A problem has come up which wasn't there before - when I try to edit a post or page, the big content editor box where the content of the page normally shows up, is blank.

    When I inspect the content edtor with Firebug (in Firefox), I note that the text is there in the HTML, but that it is not visible in the browser.

    I have tried de/re-activating and updating my plugins, and have updated to the latest version of WordPress, but to no avail.

    I suspect it may have something to do with Javascript because furthermore when I click on the 'text' tab next to the 'visual' tab of the content editor, nothing happens; and when I click on 'Screen Options' at top-right, nothing happens either.

    Has anybody had any experience of this problem, or an idea of what might be causing it?

    Any suggestions or help would be very gratefully received.

    Thanks,

    Rory. :)

  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

    This thread has the recommended troubleshooting steps, including how to look for JavaScript problems:

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

  3. wp-rory
    Member
    Posted 2 years ago #

    Hi,

    Thanks for getting back to me with that info. Step 2 of the Javascript error diagnosis instructions (http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors) - that is, enabling script debugging in wp-config.php, has fixed the problem.

    The advice on that page is to report the fact that script debugging fixed the problem here in a troubleshooting thread.

    Now having done that, is anybody able to advise on how the problem might be fixed permanently, assuming this script debugging is intended as a temporary measure?

    Many thanks again,

    Rory. :)

Topic Closed

This topic has been closed to new replies.

About this Topic