Support » Fixing WordPress » content editor html trails not showing

  • new at this wordPress thing, so if I have terminology wrong,apologies.

    when you first go into the content editor, it’s empty, and the bottom line is showing words: and the date/time of the last edit and who did the editing.

    you then type a whole pile of text, and start applying a bit of formatting. eg top line inside <h1> tags and the text correctly goes big and bold.
    I then move the cursor into the formatted text and then the problem starts.
    when I look at my editor, I can see a line above the word count showing me the html tags
    eg h1
    this changes to longer tags as the formatting gets more complex.
    that’s what happens on my screen.
    when I go to the wife’s screen (she’s doing editing as well), the line containing html tags simply does not show. No matter what we do, that line never displays and I can’t see the html trail.

    • we are both using win10, chrome browser, both in WP as admin,
    • visual tab is active (top right of the editor)
    • screen options show everything except ‘slugs’

    I’ve checked all over the place, can’t find any switches to turn that line on off.
    anyone got any ideas where that toggle switch is.
    the reason I ask is that , as a newbie, she copied a load of text from a website and ended up with 11 nested div’s in the text (eg div>>div>>div>>div . . . ) and she just could not see the hidden formatting. (I could see it when I looked on my screen)

    I know I can use the’text only button’ or the ‘text tab’ or copy the htmlcode into notepad, then copy that into the editor but that’s not the point, the question is, how do I show that “html trail” line permanently

    anyone got any ideas please

Viewing 15 replies - 1 through 15 (of 20 total)
  • Hello, Kevin, & welcome. Just out of curiosity, what themes are you & your wife using? Sometimes themes have different functionality, & this may be the difficulty. Please try changing your wife’s theme to what you’re using, if applicable, & see if that helps. & then let us know, please, so we can suggest other things to try if that doesn’t work.

    It may be themes, but we are actually editing the same site, same page(s) just on different screens to speed up the process.. It’s actually a flatsome theme. to control a wooCommerce site.
    She edits page 1, encounters a problem, I open that same screen, and I get two rows of icons and the html trail at the bottom.

    I’ve been chatting for an hour to wooCommerce support, but they assure me that they use the standard editor from WP.
    one thing I’ve just noticed in the last couple of minutes, the editor that I use has two lines of icons, the top line starts “Formats”, and ends “shortcodes”, and the next line starts with “crossed out text”, and ends with “keyboard shortcuts”
    looking on the wife’s screen, there’s only the top line starts “Formats”, and ends “shortcodes”
    there is no second line.
    Its as though, as a user (she’s logged in as another user), she doesn’t have access to the full range of editing but that’s not a bad thing sometimes though 😉

    maybe thats a clue.
    whatever it is, its certainly strange.

    Are you both logged in as administrators, Kev?


    Hey, Kev, do I have this right? Are you logging into the same site, at the same time, on 2 different machines? Is that what you’re saying?

    exactly that.
    each person logs in, edits one product, if the other is working on it, it generates an error message and you back off, otherwise your free to edit that one A little bit more than that, but yes, we are both working on the products to speed things up.

    its when she does something (cut and paste from our existing website), can’t see the html tags, and can’t work out whats going wrong, then I have to step in with 30+ years of programming and web design and work out what shes done wrong.

    it actually works very well IF you both have the same editor.
    as the editor is built in, I just can’t see why she has an abbreviated version compared to me.

    First, did she perhaps accidentally press the ‘distraction-free’ button? 2nd, are her Windows/browser display settings different from yours such that the formatting might be hidden?

    Lastly, (& this has nothing to do w/your problem), but if you’re using Woocommerce, & you want to build a fully accessible site, then I’d discourage its use in its current implementation, as the dropdown lists for selecting countries, states, provinces, etc, are not accessible using the keyboard. Thus, any pwd who must use the keyboard exclusively will likely be excluded from buying anything from you until this gets fixed. They have several support tickets on their desk now regarding this issue. Normally I wouldn’t have said anything, but, given your username… Just FYI, you understand.

    No, I’ve used the distraction free button, its not that. we’ve checked virtually everything we can think of
    thanks for the heads up,

    I’m assuming you mean using this theme has potential keyboard issues or is it woocommerce.
    You’ve probably guess that It’s an early use of wooCommerce and picking the right theme is not that easy.
    if its the theme, then it’s only been bought a couple of days ago, and I havn’t gone far, so now’s the time to rectify.
    if its woocommerce, thats again another totally different issue.


    It appears to be Woocommerce, Kev. The implementation on both the front & back end as it concerns dropdown lists is quite inaccessible. So those using the keyboard only will likely not be able to purchase goods because they can’t enter their state/province & country correctly. Likely not what you’re looking for if you’re catering to pwd’s.

    Just out of curiosity, could you please do me a favor? Could you please switch to 1 of the default WordPress themes (they begin w/the word ‘twenty’) & see if your issue persists?

    swaping to a base theme – will do, but its late here in the Uk, and I’ll do this tomorrow (12-15 hrs time) and then feed back
    dropdowns will become a big issue. we do lots of products that have a choice of “seat size” “colour” and they are currently all being defined as dropdowns to save on screen real estate.

    I need to play a lot more with the dropdowns, I have one item with just two dropdowns and the second beings shown/changed according to the first selection, but trying to do the same with 200+ options would be a nightmare.

    one last question, what does “pwd” mean. We dont know of this word in the UK, unless it means password, and I very much doubt that.

    thanks for the responses.

    ok, a bit more googleing (is that a real word), and pwd means “persons with disabilities”

    never come across that abbreviation before, you learn something new everyday and we’ve been working with this group of people for 15+ years.

    Hmm, I thought pwd was a basically universal abbreviation for persons/people with disabilities. I’m sorry for assuming that familiarity. It is a pretty common acronym amongst the disabled/pwd’s. I personally prefer it to ‘disabled’ as the latter word always reminds me of a car stalled in the middle of the road that’s basically in everyone’s way, & folks are all trying to get around it, honking & cursing, while it can’t go anywhere. I certainly don’t feel that way about my life, & I suspect that applies to most pwd’s. & I suspect most friends & families of those w/disabilities don’t view them in that light, either. Just my two pence/cents, & it’s likely worth precisely what you paid for it. Lol.

    I do wish you great success in your venture.

    thought provoking, the missus has been arthritic since she was 15 (40 years) and is classified as disabled, but I think she would like the label “pwd”. it’s just got that slightly better ring about it.

    any way. GREAT NEWS.
    since the last response (over an hour ago), I found the answer

    I ended up looking at the source code being generated when in the editor, and noticed the TOGGLE, that led me to …..
    and eventually, I found it.
    its the little icon near the end of the toolbar that looks a bit like two keyboards stacked on top of each other (just before shortCodes).
    it’s actually the “Toolbar Toggle (Shift-Alt-Z)”

    this then turns on the second row of tools on the tool bar and also the html-path row at the bottom of the editor.
    interestingly, it contains useful buttons for UNDO, “paste as text”, “clear formatting”, “redo” and “keyboard help”

    I also, as a test, created a new user. guess what … the second (useful) row isn’t turned on by default. !
    something to bear in mind in the future.

    it’s nice to find the result,
    Thanks for all your timely responses, (especially the keyboard navigation) really do appreciate it



    one last thing, can you give me any url’s point to the keyboard navigation problem please.
    I want to read up about it, and want to focus straight on to the problem rather than searching all over (and getting the wrong search terms)


    Well that irritates me, as I looked thru the TinyMCE list of keyboard shortcuts & that 1 didn’t seem to be there, though I knew there was 1–I just had slept a few times since the last time I used it & couldn’t remember what it was. I guess I’ll just have to add CRS to my list of disabilities lol. I think it actually used to be alt+f10, & that’s what it said there, but that didn’t accomplish the goal. I’m sorry, but, anyway, if nothing else, I taught you PWD–& you gave me the shortcut key I was looking for but couldn’t find.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘content editor html trails not showing’ is closed to new replies.