Support » Plugin: Page Builder by SiteOrigin » Content disappering

  • Resolved mikacns

    (@mikacns)


    We have had several pages that lost their content or have some of the content missing. It only happens on pages built with SiteOrigin builder, we’ve been using it for years but this just started happening recently.

    Some of the pages suffer from all of the content disappearing, while other have the content but some of the sections are not showing up at the front end.

    Any ideas what could cause this? I saw there are some conflicts with the classic editor, but disabling it didn’t help.

    P.S. I am using “Black Studio TinyMCE Widget” plugin for shortcode in the content that’s not showing in the front end.

    • This topic was modified 2 months, 3 weeks ago by  mikacns.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Andrew Misplon

    (@misplon)

    Hi, sorry to hear about the hassle.

    Please, can you let us know which page we should check on your site to see the problem?

    There aren’t any open issues with the Classic Editor, if you have any new information about a problem with the Classic Editor we need to log, please, let me know.

    The home page is missing H4 class headers. It’s worth mentioning that none of the issues seems to be happening on the staging website, but only on the live website. I already excluded a bunch of factors that could explain this, but I am open to more suggestions.

    – Disabled plugins 1 by 1 to test it out, no results
    – Rolled back SiteOrigin PageBuilder, SiteOrigin Widget Bundles plugins to previous versions
    – Deleted/re-installed those two plugins
    – Disable caching / turning on development mode in Cloudflare
    – Changed PHP version of the server

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks for all the feedback.

    * Where on the page are the missing h4 tags meant to be? There are some h4 tags in use on the page now.

    * If possible, please, take a screenshot of the Page Builder row and widget that’s missing and upload it to imgur.com or the sharing site of your choice.

    I found a workaround using SiteOrigin Headings widget on the home page, the headings are back there now. It previously worked (and still works on staging) with Visual Editor widget, so there is clearly a problem there.

    I created a test page where you can see the missing headings – https://lostempireherbs.com/test/ password is siteorigin

    Here is the backend. It’s not that widgets are missing, but the title is there on the backend and no where to be found on the front end.

    https://imgur.com/7eSwsSN
    https://imgur.com/q3GhS5b

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks, that’s clear now.

    On the test page, is there any change if you remove one of the Visual Editor widgets and replace it with a SiteOrigin Editor widget, with the same content? And if that also fails, does the same issue persist if you use the Text widget?

    There is, but the header is too small (without additional CSS adjustment). See the updated page.

    Also, the problem persists with the text widget.

    Plugin Author Andrew Misplon

    (@misplon)

    To resolve the issue with the Visual Editor and Text widget would require troubleshooting. With a distinct error, you’d need to temporarily deactivate all plugins except for those authored by SiteOrigin and Black Studio and see if a working baseline can be established. If a working baseline can be established, you’d then reactivate your plugins one by one, checking the issue after each activation.

    Alternatively, you could use the Editor widget and adjust the title styling. We don’t usually assist with styling within our free support scope. The rule would be:

    .widget_sow-editor h4.widgettitle {
    	
    }

    Insert the declarations you want within the rule.

    You could also go to Page Builder > Settings > Widgets > Widget Title HTML and ensure there aren’t any formatting errors in that field.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.