Support » Plugin: Nimble Page Builder » Content disappears after publishing

  • Hey Nicolas & community,
    I’m experiencing a serious problem with NimbleBuilder in combination with the customizr pro theme. When I add a module like image or text module to a page and asign an image or text to it, it is still displayed in the livepreview:

    However, the added content disappears completely after publication. You can see the added module in the section navigator as belonging to the section (id : loop start), but the page still remains unchanged:

    Hope you can help me to diagnose the error.

    • This topic was modified 5 days, 10 hours ago by Alexander. Reason: added images

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Nicolas

    (@nikeo)

    Hi, thanks for reporting this issue.
    I’m not able to reproduce it on a test site.
    Can you list the needed steps in order to reproduce the issue, when all plugins are disabled ? ( you can use Health Check Plugin as an administrator to disable your plugins and switch themes without modifying the appearance of your website for your visitors ).

    If needed, here’s a troubleshooting workflow.

    1. Use the latest software versions : make sure WordPress, your theme and plugins are all updated to their latest versions.
    2. In your WordPress admin, go to settings > general and verify that your WordPress Address (URL) and Site Address (URL) are identical. The website will not run properly if the urls are different.
    3. Cache plugin : if you use a server cache or cache plugin, clear it’s cache content and disable caching via it’s settings.
    4. Browser :
    • Check for plugin conflict : Install the WP official Health check plugin. Activate the troubleshooting mode. Then deactivate all of your plugins. If it fixes the issue, re-activate your plugins one by one, until you identify the plugin in conflict.
    • Child theme : activate the parent theme if you use a child theme
    • Theme problem : try to activate a WordPress default theme ( Twenty … )
    • Javascript : make sure you did not insert custom javascript code ( like analytics, subscription popup… ), for example in a widget, that could break your site.
    • To log possible code errors on your website, enable WP_DEBUG mode and log the output of the debug.log to a file that you can share on http://pastebin.com/ or https://gist.github.com ( to get a debug log file you need to set define( 'WP_DEBUG', true ); and define( 'WP_DEBUG_LOG', true ); in your wp_config.php file.

    Thread Starter Alexander

    (@john0wick)

    Dear Nicolas,
    thank you for the fast reply. WordPress as well as the Nimble Builder plugin are on their latest versions. I’ve installed and activated the Health Check Plugin alongsite with only the Nuble Builder. The browser cache is cleared. Unfortunately the problem persists. If I add some content to a new site, it disappears after publishing. The interesting part is: if I take a look on the section navigator it displays me a high amount of modules on a freshly created test site:

    If I investigate what content is inside those modules I can recognize them from another existing site. So a little bit background: As I created multiple sites of the same structure I’ve used the export function of Nimble Builder and exported the first finished site. Then I imported this file (like a template) to a newly created blank page under the “Current page options”-menu. Once I did a mistake and imported the same file not under “Current page options”-menu but under “Site wide options”-menu. Could this be the origin of the problem?

    Thank you in advance

    Plugin Author Nicolas

    (@nikeo)

    OK.
    Yes the global import by mistake could definitely be the cause of the issue.

    A possible solution would be to remove the content imported by mistake in the global options in the customizer > Nimble Builder > Site Wide Options > Remove the sections displayed in global locations

    Then I would try to re-import the content of the page properly in the current page options.

    Thread Starter Alexander

    (@john0wick)

    Hey Nocolas,

    I’ve tried that, but I got the following error every time I try to remove the sections:

    Any suggestions?

    • This reply was modified 5 days, 7 hours ago by Alexander.
    Plugin Author Nicolas

    (@nikeo)

    OK thanks.
    I’m exploring the problem locally to find a solution.
    I’ll keep you posted soon.

    Thread Starter Alexander

    (@john0wick)

    Thanks for keeping up with me!
    In addition, Nimble Builder even doesn’t let me roll back the global sections. After setting a previous one and publishing it still remains on the current version:

    Another confusing thing is that, even there are nimble-sections, it says that the page was not customized with nimble builder:

    Thread Starter Alexander

    (@john0wick)

    Hey Nicolas,

    is there any possibility to backup all the pages that were built with NB and then reinstall the plugin? So all the Settings will be resetted and after that to restore the pages from the backup?

    Plugin Author Nicolas

    (@nikeo)

    Hey Alexander,
    There’s currently no option to backup all pages built with NB. You can export/import pages on a per page basis. You can also remove all data created by Nimble Builder and stored in your database ( options, custom post types, transients, … ) or as stylesheets : page customizations, custom sections, custom templates, options, CSS stylesheets. This option is available in admin > settings > Nimble Builder > options.

    A new version of the plugin has been released yersterday, it fixes the problem of removing global sections. It also prevent users to import local content globally.
    Let me know if it solves your problem.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.