Support » Plugin: Content Cards » Content Card doesn''t show image

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Arunas Liuiza

    (@ideag)

    Hello and thanks for trying Content Cards out.

    Content Cards rely on OpenGraph data to generate the rich snippet. The link you are trying to embed (http://dragosteadinfarfurie.ro/blatul-de-pizza-preferat/) does not provide og:image meta tag, so Content Cards does not get the information about the image.

    As you are trying to embed from your own site, the solution would be to provide said meta data. You can enable that by using one of a handful of plugins – Jetpack, Yoast SEO and many more. The plugins I mentioned above do much more than insert the required metadata, but there also are small plugins, that do just that, like [OpenGraph](https://wordpress.org/plugins/opengraph/) and others. Any of them will do the job.

    Good luck, Arūnas

    Hi, thank you for your prompt reply. I’ve installed Yeost SEO and nothing changed. Is there something else that I need to do in order for Content Cards to work even with links on my website?

    Tried also OpenGraph earlier, but it also didn’t work. I kept only Yeost SEO as I will use it from now for my website.

    Thanks again.

    Plugin Author Arunas Liuiza

    (@ideag)

    Hello again,

    You have to enable OpenGraph support on Yoast. Follow instructions from Yoast knowledge base: http://kb.yoast.com/article/219-getting-open-graph-for-your-articles

    Once og:image meta tag shows up on your pages source code, Content Cards should pick it up. You should also note, that Content Cards caches the data it extracts from the link, so if you tried embedding the link before it had proper meta data, it will take Content Cards a while to refresh the cache. There is a setting i Content Cards Settings screen, that controls the caching interval.

    If you want to force Content Cards to recrawl the link, you can add a meaningless query string to the end of the link, that way Content Cards will treat it as a new link. For example you can change http://domain.com/article to http://domain.com/article?sddffsd. That link will still point to the same article, but Content Cards will recrawl it and get the updated data.

    Plugin Author Stanislav Khromov

    (@khromov)

    Like Arunas wrote, since you installed Yoast SEO your OpenGraph data is populating correctly but the old data is still cached, so you will have to wait about 24 hours before the card will be updated.

    I just embedded the post in question and the image works fine:
    https://dl.dropboxusercontent.com/u/2758854/content-cards-embed.png

    If you don’t want to wait for the cache to clear, you can follow Arunas advice to add some extra data to the end of the URL to make it refresh faster.

    Thank you very much for your answers. It all works now. Thanks for your help, I actually learned something new 🙂

    Hey! I noticed that my organization’s logo wasn’t showing up. Do I need to resize my header logo? http://childrenfirstcisbc.org/early-childhood-development/

    Thank you!!!!

    Plugin Author Arunas Liuiza

    (@ideag)

    Hi! The site logo on the content card is generated via favicons. Your site seems to lack one. You can add a favicon to a wordpress website via Site icon setting in Customizer.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Content Card doesn''t show image’ is closed to new replies.