Support » Plugin: Multiple content blocks » Content blocks not showing "remote HTTP requests" message

  • Resolved dnuon


    I am using plugin v3.0.1 with WP v3.4.2 and I have 3 the_content() functions being called by the page template. I get the message:

    Your server doesn’t allow remote HTTP requests using wp_remote_get. You will have to visit this page manually to update which blocks are used on each page.

    When I visit a saved draft of the page using the link in the message and return to edit the page, Editable blocks does not show up and the message remains.

    When I publish the page and visit it, the entire MCB box disappears (no message or Editable blocks) and the option in the “Screen Options” tab the MCB checkbox disappears.

    I have contacted tech support for the host and they say that HTTP request is allowed:

    Our Administrators have checked your request for allowing HTTP requests. The HTTP requests are allowed by default (otherwise your website would not be visible on the internet). We do no see any issues on our server configurations that might have caused the error you are getting.

    Thanks, any help is appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Trendwerk


    That’s strange, somehow the wp_remote_get function still doesn’t get a 200 HTTP status. However, I cannot debug it since I cannot reproduce this error.

    When the MCB blocks disappears entirely (on a published post), this should mean HTTP requests do work, but your blocks don’t get registered. In your message you said you were using the_content three times, however, you need to use the_block(‘Block name’) for every extra content block.

    Did you use it like that or was it just a typo?

    Sorry that was a typo, I used the_block('Block name'); with ‘first’, ‘second’ and ‘third’ as the block name.

    Is there a way to “force” registration for the blocks? I only need this on one page template.

    Thanks for your help, this is a great plugin and the first time having problems.

    Plugin Author Trendwerk


    When the HTTP error doesn’t show, it should already register them correctly for that page. You can try commenting out line 69 in assets/inc/functions.template-tags.php and visit the page in the front-end, but it’s quite hard for me to debug it from a distance.

    If there’s any way you could grant some kind of access to this specific website, maybe we could take a look (however, I recommend you don’t share this information that easily, so you should only do it if you have a seperate development website or something). You can contact us through

    I apologize for the late reply. I tried commenting out line 69 in assets/inc/functions.template-tags.php but it still does not work.

    Unfortunately this is on a client’s server with their site live. And as much as I want to, I cannot setup a development site for you to debug the problem. But thanks for attempting a fix. It’ll just be harder to make edits having multiple column blocks on one editor.

    Thanks again.



    I found the problem that was causing the_blocks not to register while working on another project. I had two templates that both used the_block but in different order in the PHP processing.

    The blocks registered on the template that had the_block after the loop. But in the other template that had the_block before the loop did not register. So I moved things around to include the_block inside and/or after the loop and it started registering. Went back to the original project this occurred on, did the same thing and it now works.

    Trendwerk, perhaps you can double check this? See if this is a requirement now in v3.0.1? I recall it working regardless of placement before it updated.

    Thanks again, great plugin.




    Your server doesn’t allow remote HTTP requests using wp_remote_get. You will have to visit this page manually to update which blocks are used on each page.

    I am encountering the same problem. Commenting out line 69 does not help and I only have one template. I am using WordPress 3.4.2 and Multiple content blocks version 3.0.1.

    Plugin is not great yet. Any help is very welcome….



    Hello –

    I also have “Your server doesn’t allow remote HTTP requests using wp_remote_get. You will have to visit this page manually to update which blocks are used on each page.”

    Plugin works great on the page templates I’ve added it to, but I’m getting this message on new post pages and worst of all, on the “new slideshow” post area for Portfolio Slideshow Pro, which renders the page useless.

    I love your plugin, it is a miracle for me, but I need to be able to post new slideshows.

    Thank you!!!

    Plugin Author Trendwerk


    Sorry for my late reply.

    You can find more information about the error message here:

    Thanks alot dnuon for your debugging! It depends whether that problem occurs or not. If it’s a custom loop with WP_Query, it should be inside the loop ofcourse. But with the main query it works inside or outside, as long as the global $post variable is still in play.

    By the way, I will look at the Portfolio Slideshow Pro plugin that alot of people seem to use.

    This doesn’t help at all, since my server can do all that and the plugin worked before as it should. I have no idea why it stopped working. There has to be a different error that let’s the plugin blame the server config while it’s actually something else.

    Plugin Author Trendwerk



    We’re still working on this message. It seems to display sometimes when there are actually different problems. However, it does have something to do with the fact that the blocks cannot be initialized from the admin area.

    You can try this:

    Let me know if it works.

    I had this same problem. I solved it by switching the theme and then switching back. Hopefully this gets rectified in a future update so that my client doesn’t experience a similar problem. Thanks for creating an amazing plugin!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Content blocks not showing "remote HTTP requests" message’ is closed to new replies.