The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Multiple content blocks
[resolved] Content Blocks have turned into custom fields (11 posts)

  1. dickovski
    Posted 3 years ago #

    Just updated to version 3.0 and all my content blocks have turned into custom fields. The info within the custom fields still displays correctly on the front end of the website and I can edit the custom fields but don't see the actual content blocks editing window any more.

    Anyone else had this problem.

    I reverted back to the old plugin and the editing blocks reappeared but with nothing in them. The data remained in the custom fields.


  2. Trendwerk
    Plugin Author

    Posted 3 years ago #

    Your problem probably has the same cause as these threads:

    Multiple content blocks will always appear in Custom Fields, since they show all post meta.

    Can you try this as a fix?
    1. Comment out line 92 of assets/inc/class.MCB.php
    2. Visit the page you're trying to edit in the front-end
    3. Check and see if the blocks appear

    If this is the case, it will be fixed in the upcoming release and you can keep it commented until then. You can find more information on this topic in the above mentioned threads.

    Hope that helps!

  3. dickovski
    Posted 3 years ago #

    Thankyou so much for this - worked a treat.

    Just to give you some background to the problem - when I updated the plugin it initially created an error which I stupidly ignored and just tried again. The second time it seemed to install fine but the content blocks editing windows had dissappeared and the data from them had been moved into custom fields. The site still worked fine on the front end so I didn't notice until I tried to add a new post a day later.

    Regards Richard

    Can I safely delete the custom fields that were created now or just leave them?

  4. Trendwerk
    Plugin Author

    Posted 3 years ago #

    What happened is that when you updated, the data was migrated to the data for the new version of MCB. When you reverted the plugin, your data was still migrated to the newest version.

    The problem probably lies in your server settings. In the next half hour or so the fix (actually just an error catch & notice) for this problem will be released, so stay tuned.

    If the custom fields start with 'mcb-' you should leave them there - they're the actual content of the content blocks.

  5. dickovski
    Posted 3 years ago #

    That's what I thought. Thanks again for the fantastic support.

  6. nebcreative
    Posted 3 years ago #

    I am having same issue as client cant edit the content in the 2 columns. I did see the custom fields where it is editable but they arent comfortable with that. When will this be working properly? And i made changes listed above but it didnt fix issue in wp admin

    I have the site mirrored and the content blocks in editor are not showing up for the 3.01

  7. ehron.asher
    Posted 3 years ago #

    Sent the plugin developer an email about this, but while I await a response, I will post here to see if anyone else has a solution for this:

    Having updated the plugin, almost all of my website content disappeared because I used MCB throughout my very large website. The plugin disappeared from my backend Pages as well.

    So, I reverted to an earlier version of the plugin, which has made the MCB reappear -- however all of my content which was in the MCB have moved to Custom Fields, along with the MCB-prefix, but the MCB fields the plugin provides are empty. I have over 50 pages of content, each with about 10 different content blocks... What can I do to get my content back into the content blocks where they belong without manually cut and pasting? This would take me several weeks of work to fix if that is my only option.

    Please HELP!!!!!

  8. Trendwerk
    Plugin Author

    Posted 3 years ago #

    3.0.1 should actually catches an error related to this. Have you tried updating to 3.0.1? Do you get an error in the admin panel (when editing a post or page) that wp_remote_get doesn't work because your server doesn't support HTTP requests?

    Can you try visiting a page in the front-end and see if your content block re-appears?

    You probably haven't lost your content, it's been migrated to 3.0. We should be able to fix this! I've also read your e-mail, but let's continue to talk here.

  9. ehron.asher
    Posted 3 years ago #

    I thought I already explained this, but will do it again for clarity. I originally got the "wp_remote_get" error. Then when I updated the plugin, that error disappeared, as did the entire plugin MCB boxes from the back end. I had to revert to a much earlier version to get the plugin boxes to reappear on the back end pages - and the content boxes themselves reappeared on the front end, but without the content in them. On the back end, I can see all of the content, but it has been moved to custom fields. The issue now is how do I get that content back into the MCB fields?

    I am currently at the reverted version, not the updated version.

  10. ehron.asher
    Posted 3 years ago #

    Just to be sure, I re-updated to 3.0.1 and it appears after the update and resetting my page template, the problem is now fixed. Thank you for your work.

  11. Trendwerk
    Plugin Author

    Posted 3 years ago #

    Oh, that's great to hear! Do you still get the HTTP error?

    Glad to hear your content is saved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Multiple content blocks
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.