Support » Fixing WordPress » content, excerpt and comment_text not showing after upgrade to 2.3.1

  • I have just upgraded one of my sites ( from 2.2 to 2.3. Everything went smoothly, except that neither the_content nor the_except nor comment_text are working now!

    Everything else shows up, the title and id, the tags and categories, the metainfo around the comments, everything inside and outside the loop except those three things. I looked in the database, and the content is still there in the posts and comments tables, everything just the way it was in my backup, line for line; those three items are just not getting called, somehow. There are no error messages–just no text either.

    I tried deleting and uploading a fresh copy of post-template.php, and that didn’t help, so it doesn’t seem to be because of corrupted php. I double checked the code against the new version of Kubrik, and it’s identical, so it doesn’t seem to be a code snafu. I tried deactivating all of my plugins in case there was some weird kind of conflict, and that didn’t help either.

    I currently have things working by using direct calls to the database, but that is a huge pain and doesn’t really tell me what went wrong. The other site I did an identical upgrade on did not have this problem, and it’s on the same domain, so it doesn’t seem likely to be a server issue, either.

    I am really at a loss, and would appreciate any suggestions.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Also tried deleting the whole folder of php off the server and reloading it. That didn’t work either.

    Tried reloading the table to the database from the backup, too, and that didn’t work either. Am totally stumped.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘content, excerpt and comment_text not showing after upgrade to 2.3.1’ is closed to new replies.