Support » Plugin: WP REST Yoast Meta » Content showing sub categories instead of string data

  • nicolauria

    (@nicolauria)


    When I first installed this plugin I was able to use the yoast_meta graphql category with ‘name’, ‘property’ and ‘content’ as the available sub categories. For some reason now the ‘content’ portion is showing up with sub categories. There is also nested yoast_meta tags. One inside of the other. All I want is the name, property, and content. Screenshot link below. Any help is appreciated.

    screenshot

    • This topic was modified 2 months ago by nicolauria.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Richard Korthuis

    (@rockfire)

    Hi @nicolauria

    Thank you for using our plugin!

    Unfortunately I am unable to view your screenshot (ERR_CONNECTION_TIMED_OUT), would you be able to upload it somewhere else and add a new link in this topic?

    nicolauria

    (@nicolauria)

    Hi Richard,

    Here’s an updated link: https://ibb.co/QQj4HN7

    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @nicolauria

    I see what you mean. It looks to me that some other plugin or code is adding content to the yoast_meta. It seems a complete post object has been inserted in the yoast_meta > content, because as you can see there is a new yoast_meta block within the content. That is not something our plugin does.
    Are you able to deactivate the other plugins (maybe one at a time) to see if the problem disappears?

    nicolauria

    (@nicolauria)

    Hi Richard,

    I tried disabling my other plugins but this did not resolve the issue. It’s strange, the error disappears at times and the ‘yoast_meta’ graphql option appears to be correct with ‘content’ as a end level option. Then it will switch back to ‘content’ having nested fields.

    Here is the specific error message: “Field “content” of type “wordpress__wp_media” must have a selection of subfields. Did you me an “content { … }”?”

    Thanks @rockfire

    • This reply was modified 2 months ago by nicolauria.
    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @nicolauria

    Unfortunately I am unable to reproduce this error at this time, making it really hard for me to debug and solve it. I will keep an eye on it, but for now there isn’t much I can do.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.