• Resolved techguysa

    (@techguysa)


    So when customers fill the form in it does not send email to me informing me.

    This did work before and the settings are corect (send mail on) send to [Adminemail] etc

    my other forms working (things like inquiry etc)

    I am unsure if this is from latest update

    my wordpress and evyerhitng else is on the latest version 5.6.1
    this plug in Version 4.09.05

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Njones35

    (@njones35)

    Hi @techguysa

    I’m sorry you’re having trouble with this. I’ll do my best to get this resolved for you ASAP.

    In most cases, we discover that emails leave the website correctly, but are sanitized or deleted before delivery by internet spam protection measures. Because spam protection rules are constantly getting stricter, a form that previously worked can sometimes stop working out of the blue, even if nothing has changed on your website.

    Do you currently have an SMTP plugin installed to send your emails? If not, I recommend installing and configuring one straight away. Most SMTP plugins will do the job, but I’d recommend looking for one that includes message logging – these logs can be useful if we need to investigate the issue further. Personally, I use a free plugin called “Post SMTP”.

    SMTP sends messages in a way that looks more legitimate than the built-in WordPress mail service and helps your messages pass spam filters.

    You should also check that your email messages are configured properly – here are 7 important things to check:

    * Your SUBJECT line must not be blank.

    * Your FROM address MUST match the domain of your website. It is often best to set up a dedicated email for this, like noreply@mydomain.com.

    * Your TO address should never match the FROM address. This looks unusual and can trigger spam deletion.

    * If you specify a REPLY-TO address, it should never match the TO address.

    * While you can include multiple addresses in your TO field, it is best to use the CC and BCC fields for additional recipients.

    * Many spam filters are triggered by too many recipients in one email. For large lists (50 or more recipients), consider a service like Sendgrid or SendInBlue.

    * Minimize the links you include. Email messages with lots of links may trigger spam filters.

    Let me know if that helps.

    Thread Starter techguysa

    (@techguysa)

    Hi thank you for the response.

    I just installed that plug in *SMTP

    However test email keeps failing

    my smtp is smtpauth.<domain>.co.za and in outlook for example on security is set to AUTO which works fine there

    But on yours its eitehr None/SSL/TL (if i remember correctly

    and neither are working this part could be the ruling on my hosts email server unsure what AUTO on outlook does but they work just not via plug in.

    I do put the user name and pass on it.

    See image here as an example
    https://www.techguysa.co.za/wp-content/uploads/2021/02/form.jpg

    Plugin Support Njones35

    (@njones35)

    Could you please contact the Post SMTP support team directly for support setting this up? I’m afraid we do not make this plugin, so cannot offer setup instructions ourselves.

    Thread Starter techguysa

    (@techguysa)

    I will but i got it to work by changing the from [admin_email] to
    [sitename] <form@techguysa.co.za>

    Only problem is on my email if i hit reply it doesnt go to the customers email (no clue how you got that right) it just set to email to myself.

    No train smash on that

    Thanks for the help

    Plugin Support Njones35

    (@njones35)

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.