Support » Plugin: Contact Form 7 Polylang Module » Contact forms not showing right language

  • Resolved danc77


    Hi there

    Im using latest WP, CF7, Polylang and CF7-polylang module.

    Can’t follow video since there is no drop down with language near to add new button. If i use the + and make a new form, it does use proper language tags but it saves the form in main language.
    If I change main language to desired one manualy and link the form between em, on frontend still only main language form is shown.

    Im not sure what im missing here? Any suggestions?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Aurovrata Venet


    Hello Dan

    there is no drop down with language near to add new button

    that means that there is an issue with the javascript on your page load. One or more scripts loading on your page must have error I reckon which stops the execution of the CF7 Polylang plugin scripts from executing properly. Can you inspect your page and see if any errors are reported on the console?

    Thanks for reply can’t see any JS error nor in logs, nor in browser log nor in debug log.

    but debug log does show an error:
    call_user_func_array() expects parameter 1 to be a valid callback, non-static method Wp_Categories_Widget

    not sure of connected with Contact form

    Solved the above error, still no drop down menue, no JS errors in logs

    Plugin Author Aurovrata Venet


    Hi Dan,
    that’s strange. I just realised that wp4.7 has made a small change in the table list html structure which prevented the language dropdown from showing up.

    I just fixed this and released a new version, please update and let me know if that fixes your problem.

    The drop down menu is now working, and the forms are linked in between with appropriate languages.
    But the form is shown in main language on website only, i.e. it is not picking the translations

    I am also having the same problem @danc77 is having. Please help.

    Plugin Author Aurovrata Venet


    Ah yes, that’s because you are using the same form shortcode for each of your translated page.

    You need to make sure you use the right form for each translation. The form id changes for each translation.

    Please take a look at this thread to give you can idea of how to get it to work.

    However, with the new v1.4.0 that just got released, I have introduce form keys and portable cf7 shortcodes. Using the new portable shortcodes not only allows you deploy your code to a server without having to worry about cf7 ids, but it also allows you to automatically load the correct translation by using any of the shortcodes from one of the translated forms. This will solve this problem.

    Hello there

    Updated the plugin, updated polylang too with today relased version.

    no dropdown menues nor languages shown in contact form menu (cf when opened shows connected translations).

    In regard of portable shortcodes im not sure if im clear how to set it. Cant see any option page or menu for your plugin at all

    Plugin Author Aurovrata Venet


    Hello Dan,

    not sure why the language dropdown don’t show up anymore, I will need to check on my server and get back to you on that.

    As for the potable shortcode, there is no settings, you simply use the shortcode displayed in the table. Instead of using the form id, it now uses a form key which you can make unique for each form, but the same on all your servers (local and deployed). Hope that clarifies your doubt.

    Thanks for prompt reply

    only shortcode i can see is regular one

    looks like this

    [contact-form-7 id=”12345″ title=”ContactForm”]

    Plugin Author Aurovrata Venet



    I realised I made a mistake in an include path which prevented the new table list showing up in the dashboard.

    I released a fix with v1.4.1. Could you kindly check again.

    Confirming working as expected now.

    Thank you!

    Plugin Author Aurovrata Venet



Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Contact forms not showing right language’ is closed to new replies.