WordPress.org

Forums

Contact Forms not sending emails (2 posts)

  1. Genuanceerd
    Member
    Posted 1 year ago #

    Tested these 3 contact form plugins:
    Contact Form 7
    Easy Contact Form
    Contact Forms

    I tested it on a test location, and my whole website worked perfectly fine. All e-mails were sended nicely.

    Now this website is live and none of the above forms are working.
    I found another thread like this:
    http://wordpress.org/support/topic/contact-forms-not-sending-emails?replies=14

    And in that topic there was a plugin mentioned, WP Mail SMTP, which I now have installed. The sending of the mails is working now again, but I receive them as spam. I think that got something to do with the settings, so I will try that later again.

    My question is, because I've read in the other topic that it got something to do with the hosting, why do I need to install the plugin in order to make the forms work?

    Cheers,
    Eddy

  2. mudwoman
    Member
    Posted 1 year ago #

    I am having the same problem. However, older forms DO send the email, so it appears to be a problem with just this form I created since an update. I hesitate to update again, because we're in the middle of a registration drive, and I'm at least getting registrations in the data base. I also hesitate to add the SMTP plug in for the same reason. But this bothers me. I do NOT think it is my hosting, since the other forms still work. It's just now working with this new one.

Topic Closed

This topic has been closed to new replies.

About this Topic