WordPress.org

Forums

Contact forms are not being sent to email (9 posts)

  1. SageMillard
    Member
    Posted 1 year ago #

    http://www.sageinternationalltd.com/wp/sage-international-quote-request-2/
    The contact form we are using as a quote request form is not being sent to our sales email address which is sales@sageinternationalltd.com.

    I have tried to request a quote myself and I never receive a response.

    [Moderator Note: Please ensure that you are embedding links correctly in your posts. Link corrected.]

  2. karpstrucking
    Member
    Posted 1 year ago #

    Out of the box, WP will send all outgoing emails using the PHP mail function on the server, which can be unreliable (especially on some large, cloud or value hosts). In addition, many services will incorrectly flag these emails as spam, so double-check your spam folder at the receiving end.

    I would recommend using an SMTP plugin - this will connect directly to an SMTP server for all outgoing email, which is more reliable and less likely to be incorrectly flagged as spam.

    There are several of these, but I generally use Callum Macdonald's "WP Mail SMTP": https://wordpress.org/plugins/wp-mail-smtp/

  3. webbrewers
    Member
    Posted 1 year ago #

    2 other possibilities:
    If you use an spf record, make sure it includes the ip or domain name of your host.
    More here: http://365.webbrewers.com/blog/Lists/Posts/Post.aspx?ID=44
    Post is about Office 365 but the same principles apply.

    Some cheap hosts don't allow mail to be sent unless the sending address exists on their mail server. Sometimes adding the address even if you don't have it connected or use it is a workaround.

  4. SageMillard
    Member
    Posted 1 year ago #

    Ok I've contacted my geeks... they are working on it... in the mean time I wanted to add some info for you wonderful folks that took the time to answer.

    We are using Ninja forms v2.6.5, I have three email accounts in the admin field of two different forms that should receive the contact email. Two are our sales accounts and one is the geek's address for testing. he is receiving the emails every time... the other two addresses are not getting anything. All of the accounts are hosted by Godaddy's wild west services.

    He did add a hotmail.com address in there as well to see if it would come through. It did come through for him into his junk folder... but it came through.

    WP version is also 3.9.1 not 3.3.1.

    Any other ideas?

  5. webbrewers
    Member
    Posted 1 year ago #

    Do all 3 addresses use the same domain?

  6. SageMillard
    Member
    Posted 1 year ago #

    No. when the project is finished We hope that only the one domain will be there but for testing we have a couple different ones in there. And they all receive the emails... while the ones with the same domain name as the site are not being received. So... the site is sageinternationalltd.com, the emails at that domain are not receiving emails but the the test accounts at hotmail and yahoo are getting everything just fine.

    good times.

  7. webbrewers
    Member
    Posted 1 year ago #

    Your spf record excludes any server from sending email except the one where you host your email (which I think is Go Daddy). The Go Daddy server the site is hosted on is probably different so you may want to include that ip in the spf record. Many isp's check the spf record and reject mail not originating from an authorized server to deter spoofing.
    http://365.webbrewers.com/blog/Lists/Posts/Post.aspx?ID=44

  8. SageMillard
    Member
    Posted 1 year ago #

    right. but why are all other emails able to receive the emails just not the one that it is originating from?

    hey karpstrucking, If I install that plugin, how do I point ninja forms to it? I don't see any options for that.

  9. SageMillard
    Member
    Posted 1 year ago #

    OK! the resolution was that the server was set up incorrectly. the support group for Go daddy found the issue and repaired it. Something about where the email was pointing for internal addresses or something to that effect. so it wasn't the plugin or wordpress it was the server itself.

    thank you to all who replied! Hope this help someone in the future!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.