Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » Contact Form says Captcha field is required

  • Resolved altjx

    (@altjx)


    So I was trying to submit a form and had an issue with the contact form not working because it was requiring a field for the reCAPTCHAv2. However, I read somewhere else on here that it’s because there may be a conflict of captchas on the website.

    This is the only plugin to my knowledge that requires captcha, and I just removed WP Simple Forms that had a captcha and worked perfectly, so I’m not sure what the deal is. Additionally, I went ahead and selected the “No conflict” option so that it disables other captchas if there are any, but it’s still broken.

    Any suggestions would be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Jess Quig

    (@jquigam)

    Hi altjx,

    I took a look at the URL you shared, however it looks like reCAPTCHA has been removed and I was able to submit the form successfully.

    I checked on the page source, though, and even without reCAPTCHA enabled on the form it’s scripts were being loaded (in case you’re curious, you can see those scripts highlighted in this screenshot).

    This means that something else on the site is loading reCAPTCHA. If you’re not aware of a plugin that might be doing this, it’s most likely the theme. Some themes have a setting to turn this off, but if you don’t see any option like this is may be worth reaching out to your theme’s author to see if they can assist.

    Next, you mentioned that no-conflict mode isn’t fixing the issue. The way that the JavaScript is being loaded in the source code for the page suggests that your site is probably using an optimization plugin called Autoptimize (this will minify JavaScript and perform various changes designed to improve site performance). Unfortunately, it’s also pretty common for these types of plugins to break functionality of other parts of the site — in this case, our no-conflict mode.

    If you aren’t able to find a way to prevent the additional reCAPTCHA script from loading, you may be able to allow our no-conflict mode to work by modifying the settings on your optimization plugin. This may take a bit of trial and error, but some things to look into are:

    1) Is there an option to whitelist WPForms within Autoptimize (prevent it from changing our scripts)?
    2) Is there a way to make file minification less forceful?

    If you need further assistance with their settings, I’d recommend reaching out to their support team to see if they can help.

    I hope this gives you some ideas for next steps! 🙂

    autoptimize’s support team goes where they’re needed (well, where the plugin is mentioned) 😉

    one can exclude JS from optimization by adding e.g. wp-content/plugins/wpforms-lite to the comma-separated JS optimization exclusion list, more info on troubleshooting and exclusions in AO’s FAQ.

    hope this helps,
    frank

    Plugin Support Jess Quig

    (@jquigam)

    Thanks for sharing that, Frank! 🙂

    So I tried adding

    wp-content/plugins/wpforms-lite

    into my Autoptimize’s “Exclude scripts from Autoptimize:” section. Saved and reloaded the page and nothing has changed.

    One thing that’s a little confusing to me is that the source code shows that it’s trying to load recaptcha even though it was not enabled on the contact form. Looking at the source code now (I just re-enabled reCAPTCHA from this plugin), it doesn’t look any different other than the HTML used to build out the UI for reCAPTCHA — nowhere else is it being loaded. So it’s like the reCAPTCHA is trying to load despite whether or not it’s enabled on the contact form.

    I checked the theme and it appears that reCAPTCHA isn’t enabled (at least it’s blank — there’s no way to explicitly disable it unless you just simply don’t use a Contact form template).

    Another thing that I should mention is that I used Contact Form 7 prior to this and the reCAPTCHA worked perfectly fine, so I’m having a hard time trying to pinpoint exactly where what’s going wrong. The only reason I got rid of that plugin was because my drop down menus weren’t working as long as I was visiting the Contact Us page.

    Any additional assistance would be greatly appreciated.

    • This reply was modified 1 month, 1 week ago by  altjx.

    Got this issue narrowed down to one of my optimization plugins. Not sure which one in particular but after disabling all of them, everything is working fine. Thanks again for your help. Hopefully I can figure this out really soon.

    Plugin Support Jess Quig

    (@jquigam)

    Hi altjx,

    Glad to hear you’re getting closer! If you can narrow it down to one specific optimization plugin, it would probably be best to get in touch with their team to see if they have suggestions for you. It’s also possible that these plugins are conflicting with one another in some way — but either way, that particular team would be able to best assist.

    And if you’re willing to share what you end up finding here, I’ll make a note so that our team can keep this in mind if anyone else contacts us with a similar issue.

    Thanks! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.