Support » Plugin: Contact Form 7 » Contact form not working when adding reCAPTCHA

  • Hello,

    I just wanted to setup a contact form for my website.
    http://www.mischaelbert.de/kontakt/

    I downloaded and installed Contact Form 7 and made a small, simple contact form. Everything works fine.
    Now I just wanted to add reCAPTCHA to avoid spam.
    I went to google, registered my site and got a site-key and a secret-key which I included in the Contact Form 7 configuration.

    Then I cleared the cache of my browser and tried to use my new contact form. I now alway get the orange box telling me that it failed sending the email.

    When I remove reCAPTCHA the form works great again.

    So just for testing i deactivated every plugin except of Contact Form 7 but the problem persists.

    I also checked if the reCAPTCHA itself works: If I dont click reCAPTCHA and just submit the form, I get the error “Please verify that you are not a robot.”. So I assume reCAPTCHA itself is working.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m having the same problem. It’s only showing up in the code not on the page itself.

    What do you mean? I see the reCAPTCHA on my site.

    I just went and downloaded Contact Form 7 – reCAPTCHA plugin (By iambriansreed). Works just fine now.

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    See http://contactform7.com/recaptcha/

    You don’t have a [recaptcha] form-tag in the form.

    Yes, you’re right. I had to switch back to the old Really Simple Captcha, because i need to have my contact form working. I get a lot of mails via the contact form in the times before christmas, so I need to have this working.

    But I think I might have found the reason. When I switched from the integrated reCAPTCHA support to an external plugin called ‘Contact Form 7 – reCAPTCHA by iambriansreed’, i get a more detailed error message:
    “An error occured when verifying the reCaptcha. The form can not be submitted at this time. The errors reported were:
    http_request_failed: No working transports found
    These errors may occur on servers which don’t support SSL with cURL.”

    Maybe theres something wrong with the web-hoster I am using, so I am going to contact my hosting first.
    But this is still strange, as I get the green tick in the reCAPTCHA box after veryfying, so it seems like it works. I also get a different error message when I just dont tick the reCAPTCHA box.

    Same problem here. Contact Form 7 with Recaptcha plugin stopped working after updating WordPress. Can’t send any forms :/ Please fix.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Contact form not working when adding reCAPTCHA’ is closed to new replies.