Support » Plugin: Contact Form 7 » Contact Form Not Sending if User is Not Login

  • My website is using the latest WordPress and ContactForm7 4.9.2. I just noticed today that my contact form has an issue. I cannot send a comment if I am not login. Using both an admin and a normal user account, the test comment is sending. Before WP was upgraded to the recent version and the plugin CF7 to 4.9.2, the contact form works for unauthenticated users. Now, I am not sure which of the two is the culprit. I checked my function file and I didn’t see anything that is related to the problem. Besides I didn’t do major change on plugins or function file before the 4.9.2 update of both WordPress and Contact Form 7 and so I’m lost.

    Please advise what might be causing the issue when unauthenticated user is sending via contact form 7.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 16 through 27 (of 27 total)
  • I think @bahmannik is referring to the settings in a plugin called “Disable REST API” https://cl.ly/cd91d3a52f2a

    “Password protect” plugin seems to be causing this issue. I disabled that plugin and it is working for me.

    @david-foreman
    i installed the mentioned plugin and whitelisted the contact-form 7 routes. But it is still not working for me. Please see my attached screenshot: https://www.spielmannszug-meschede.de/wp-content/uploads/2018/08/contactform7_401.png

    I do not have the plugin Password protect as mentioned above by @hardikp

    Suggestions?

    The problem is not yet solved for me. I sat the whitelist for contact forms 7 in the Disable Rest API plugin but with no effect. I still get 401 unauthorized as response from the REST API. What can I do to fix this issue?

    Now using current version 5.0.4

    Disabling the “Password protect” plugin solve this particular issue for me. Thanks @hardikp for mentioning it.

    The problem is still not solved for me.

    I do not have the plugin “Password protect” and in the “Disable REST Api” plugin the contact-form-7 urls are whitelisted.

    Checking the cf7 items in Disable Rest API settings did work for us. We use that plugin for one site. Thank goodness for those willing to help in support forums by posting how they solved these. Thank you all.

    Now it works for me! I disabled and re-enabled the plugin and then there was a message, that i should check my formulars against possible configuration errors. I did it (everything was fine) and now the form works again.

    If you are using Webcraftic Clearfy, then „Performance | Remove REST API Links“ must be set to OFF.

    By contrast with iThemes Security “WordPress Tweaks | REST API” can be set to “Restricted access”, this does not prevent CF7 from working.

    When option subscribers_only: false is set [_user_login] tag is not working I know i had to disable but forgot can you please remind me please where

    Thanks

    I deactivated the plugin Password Protected and it works again

    Webcraftic Clearfy в ней была проблема
    Тим Ривз спасибо

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Contact Form Not Sending if User is Not Login’ is closed to new replies.