Support » Plugin: Contact Form 7 » Contact form don’t send after upgrade to WP 4.8

  • donkey.shark

    (@donkeyshark)


    Unfortunately, the contact form does not send anymore after the update of wordpress 4.8. I use the plugin on several blogs, even after a reinstallation it does not help, it still remains on the ajax animation wheel.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Leon Korteweg

    (@lkorteweghayonanl)

    +1

    For me it helps that I deactivate all plugins which blocks REST API for anonymous users. It looks like REST API is required for the “Contact Form 7” plugin.

    myexpatus

    (@myexpatus)

    +1
    any idea on how to determine the plugins that block REST API for anonymous users ?
    any other temporary fix ?

    • This reply was modified 4 months ago by  myexpatus.
    EBrockway

    (@ebrockway)

    You could also revert to this version : https://downloads.wordpress.org/plugin/contact-form-7.4.7.zip

    donkey.shark

    (@donkeyshark)

    Since the WP4.7 REST API exploit there was a reinsurance, with deactivate the plugin Disable REST API it works.

    myexpatus

    (@myexpatus)

    As explained here : https://wpml.org/errata/contact-form-7-secondary-language-form-submission-fails/

    This did the trick for me :
    Add this code to the theme’s functions.php (wp-content/themes/theme-name/functions.php):

    add_filter( ‘wpcf7_load_js’, ‘__return_false’ );

    sirector

    (@sirector)

    Is there any update available? It isn’t a solution to open the REST API to anonymous user.

    Maybe this will help anyone who has custom Form-Tags and Contact Form 7 has stopped working from version 4.7 to 4.8…
    One thing I discovered that broke some things for me was a change to Contact Form 7 from version 4.7 to 4.8 where the wpcf7_add_form_tag argument $tag is now an object instead of previously an array. So if some custom code or a plugin is adding any Form-Tags to CF7 and checking for an array result…that may have problems.
    e.g.

    
    add_action( 'wpcf7_init', 'custom_add_form_tag_clock' );
     
    function custom_add_form_tag_clock() {
        wpcf7_add_form_tag( 'clock', 'custom_clock_form_tag_handler' ); 
    }
     
    function custom_clock_form_tag_handler( $tag ) {
        if (!is_array($tag)) return '';  // you would want to check is_object now
        return date_i18n( get_option( 'time_format' ) );
    }
    

    Just chiming in to say this is still an issue with the current version of WPML and Contact Form 7 ver 4.8.1.

    Adding “add_filter( ‘wpcf7_load_js’, ‘__return_false’ );” to my functions.php file did not solve my issue, but downgrading to CF7 4.7 did fix the problem.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.